Search found 4 matches

by jotunn
Sat Dec 12, 2020 11:43 am
Forum: Windows Discussion Forum
Topic: Drivers for older and new devices (SpacePilot and CADMouse)
Replies: 10
Views: 1720

Re: Drivers for older and new devices (SpacePilot and CADMouse)

If you making a living by using 3Dconnexion device(s), I recommend you upgrade the hardware to go along with newer versions of CAx software, it's common business practice to keep competitive on the job market. And, yep, there's quite the debate about the hardware obsolescence issue. I do make a liv...
by jotunn
Tue Dec 01, 2020 10:52 am
Forum: Windows Discussion Forum
Topic: Drivers for older and new devices (SpacePilot and CADMouse)
Replies: 10
Views: 1720

Re: Drivers for older and new devices (SpacePilot and CADMouse)

Yep, you're correct. To meet your own desire, the real solution is to upgrade your hardware SpacePilot to a newer model, like the SpaceMouse Enterprise, such investment will pay for itself in the many years to come. Ok...that's what I figured the answer would be. Just figured I'd check...appreciate...
by jotunn
Tue Nov 24, 2020 8:09 am
Forum: Windows Discussion Forum
Topic: Drivers for older and new devices (SpacePilot and CADMouse)
Replies: 10
Views: 1720

Re: Drivers for older and new devices (SpacePilot and CADMouse)

How about installing a virtual machine on your system, like VMWare Player or VirtualBox virtual machine. Then you can install old version 3DxWare and use it. Appreciate the response, but I'm not sure I follow the suggestion. I do have VMWare, but my desire is to use both the CADMouse and the SpaceP...
by jotunn
Fri Nov 20, 2020 10:17 am
Forum: Windows Discussion Forum
Topic: Drivers for older and new devices (SpacePilot and CADMouse)
Replies: 10
Views: 1720

Drivers for older and new devices (SpacePilot and CADMouse)

I recently purchased a CADMouse wireless to use in addition to my SpacePilot that has served me well for years and I like a lot. Extended driver support for the SpacePilot stops at version 10.4.10. The CADMouse requires a driver newer than that to fully function (I beleve 10.5.X or 10.6.X). The CADM...