Erratic scrolling behavior from the CadMouse

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
potato
Posts: 1
Joined: Sat Sep 04, 2021 2:40 am

Erratic scrolling behavior from the CadMouse

Post by potato » Sun Sep 05, 2021 1:27 am

Hello! I hope this meets the criteria of "Avoid duplicate posts/threads", but it does touch on the driver support question that comes up all the time.

I have the CadMouse Pro Wireless and the SpaceMouse Enterprise (not wireless). I use both plugged in to my desktop, and occasionally I connect the CadMouse wirelessly with my laptop. Both computers run Kubuntu 20.04 on the 5.4.0-81-generic Kernel. I have the spacenavd package installed on both. This barely grants basic functionality though:

The CadMouse Pro Wireless:
I really like the ergonomics of it, and I don't want to go without a separate middle-mouse-button ever again. But:
- the scroll speed randomly varies and reverses. It feels a bit like pushing a car that is stuck in snow. It rocks forward, backward, suddenly gets unstuck (occasionally in the wrong direction) only to slide into the next pit to do it all over again.
- I cannot find a way to deactivate the simulated "freewheeling". It often continues to send scroll-inputs for a second or two, which quite often messes up other windows, zoom levels, adress bars...anything that I happen to move the cursor across after scrolling through something else. I believe that the freewheeling also plays into the erratic behaviour mentioned above.
- The ring-menu looks really useful, but that also doesn't seem to exist for Linux.

I have tried reinstalling the spacenavd package. I have the wireless version of the mouse, but mostly use it plugged in to my desktop with the On/Off switch in "off". Based on some threads on Stackexchange, I've tried unplugging the mouse and plugging it back in. I have also tried only using it wirelessly. So far none of these have made a difference.

On a side-note: On a new install of Ubuntu, the mouse only works for a few seconds and then stops until it is plugged out and back in. This is only fixed after installing the spacenavd package. I have never had another USB or wireless mouse that needed a third-party driver to move the cursor. Let alone an expensive, premium, "pro" model.


The SpaceMouse Enterprise:
I have managed get SOME 3D controls out of the knob at one point, but it wasn't configured right and apparently not configurable. I have never managed to get anything out of any other button, and nothing ever to show on the display other than the 3Dconnexion logo. It has so much potential, I would love to be able to use it as a macro keyboard and status display even outside of 3D software and maybe even as a controller for certain games. But so far it hasn't even worked properly in CAD.

I have found the suggestion in this forum to try actkbd or qjoypad, which I will, although I would really expect an expensive device to come with original drivers.


Are there any comprehensive fixes for either of these devices? Will there ever be original drivers for Linux? I want to recommend these devices for their potential and ergonomics, but I'm honestly just disappointed by the near total lack of driver support.

Post Reply