Blender: cannot switch between turntable/fly modes

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Posts: 6
Joined: Fri Oct 26, 2007 9:20 am

Blender: cannot switch between turntable/fly modes

Post by fiepel » Fri Oct 26, 2007 10:24 am


I have a Space Navigator PE, Ubuntu Linux 7.10 AMD64, and I grabbed the 64bit version of Blender from ... h-a-prize/

After following the instructions the Space navigator works.

However, I cannot switch to "fly mode" using button 1 as descibed in the instructions. Anybody else have the same problem, or even better a solution?
(needles to say: I did set the action for the left button to "button1" as instructed).

Also, all axis in turntable mode are reversed (in my personal perception). Is there a way to reverse the axis?

Thanks for the help.

Posts: 14
Joined: Fri Jun 08, 2007 10:53 am

Post by kidb » Sun Oct 28, 2007 6:01 am

Posts: 6
Joined: Fri Oct 26, 2007 9:20 am

Works now

Post by fiepel » Fri Nov 02, 2007 9:47 am

Thanks for the link. That worked.
In the mean time I have compiled it myself from CVS, which worke too.

Only the "feel" is still awfull, sometimes jerky and sometimes zoom wont work.

Also, my X locks up after a while of use. I suspect the 3dxsrv driver.

I'm on Ubuntu 7.10 AMD64

Posts: 6
Joined: Sun Dec 02, 2007 7:03 am

speed / sensitivity

Post by Moses » Sun Dec 02, 2007 7:15 am

it was also great if I could adjust the speed or sensitivity of the SN in blender...
in the xcube-demo the speed is much more in my favour

PS: Sorry didn't found the "Test-Forum" :lol:
And sorry for my english....

Posts: 6
Joined: Fri Oct 26, 2007 9:20 am

"Better" driver for Linux

Post by fiepel » Sun Dec 02, 2007 7:24 am

Hi, check this driver out:

I use the SVN version myself and since the sourcecode is available I am playing around with it. The only real thing missing is to set the sensitivity for each application individually, but since I only use the spacenav for Blender it does not matter to me.

You can set some parameters in:

Code: Select all

Mine looks like this:

Code: Select all

Oh, and the driver only works if you do NOT configure the SpaceNavigator as an xinput device.

Posts: 6
Joined: Sun Dec 02, 2007 7:03 am

Post by Moses » Sun Dec 02, 2007 9:04 am

Wow this is what i call a very helpful post ;) thank you!

But... sorry, how do I know if configured the SN as an xinput device? :lol:
and how can i fix this if i did so?

Posts: 6
Joined: Fri Oct 26, 2007 9:20 am


Post by fiepel » Sun Dec 02, 2007 9:13 am

If you don't know what I am talking about, than you will be fine.

You can configure the Space Navigator to be used like a mouse, but this for some reason screws-up the Opensource SpaceNav driver.

To do this you would have to add this to your /etc/X11/xorg.conf:

Code: Select all

Section "InputDevice"
    Identifier     "spaceball"
    Driver         "evdev"
    Option         "Name" "3Dconnexion SpaceNavigator"
        Option      "Mode"   "relative"
        Option      "XRelativeAxisMap"  "0"
        Option      "YRelativeAxisMap"  "1"
        Option      "ZRelativeAxisMap"  "2"
        Option      "RXRelativeAxisMap" "3"
        Option      "RYRelativeAxisMap" "4"
        Option      "RZRelativeAxisMap" "5"
        Option      "ZRelativeAxisButtons" "off"


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "spaceball" "SendCoreEvents"

But as I said, DON'T do it, or the Open SpaceNavigator driver will not work. I thought the (proprietary) 3DConnexion driver did not have a problem with this configuration.

Posts: 6
Joined: Sun Dec 02, 2007 7:03 am

Post by Moses » Sun Dec 02, 2007 12:30 pm

ok, i just wanted to get sure, whether the installation script of the offical driver hasn't done that.
And u r right, there isn't such an entry in the xconf ;)
thank you, I'll write again when I've got it working

Posts: 6
Joined: Sun Dec 02, 2007 7:03 am

Post by Moses » Sun Dec 02, 2007 3:30 pm

ok, i downloaded the stuff, unpacked the tarball, ran "make", running "make install" caused this error: "no rule to make >>install<<."

so i tried to run sudo /tmp/spacenavd-0.1/spacenavd

i think this was what i had to do... but i don't see any changes....
or is the change so little that i'm not able to feel a difference?
or should i stop/restart the properitary daemon? or start it before spacenavd?
how can i see if spacenavd is runing? can't find anything like "space" in htop...

Posts: 3
Joined: Tue Jan 08, 2008 8:12 pm

Post by Keith_Beef » Fri Jan 18, 2008 7:54 pm

I downloaded the open driver a few days ago, and compiled tonight.

I needed to install development libraries for X11 to be able to do that, and then compilation worked well.

There is no make install rule for spacenavd but there is for libspnav.

See the thread on UbuntuForums for the full story.

I'm not sure if this is going to be any use to me, yet...I'd like to ɡet it workinɡ as a ɡeneral input device for workinɡ in Gimp, and then in some CAD program.


Posts: 15
Joined: Sat Jun 16, 2007 6:24 am
Location: Greece

Post by nuclear » Thu Feb 21, 2008 11:11 am

Hi, I'm the author of the free spacenav driver.
Please, if you have any problems with it, contact me directly (, or open a bug report at sourceforge. I do not monitor this forum regularly, and I can't easily help you out here.

First of all, as this project is under development, it's generally preferable to check out the latest development version from the subversion repository, rather than downloading the released tarballs. In any case, I'll prepare a 0.2 release shortly, during the next few days.

Indeed 0.1 doesn't have an install target in the makefile, that's fixed in the SVN version for some time. In order to run spacenavd, make sure that 3dxsrv is NOT running, and just run the binary as root. In the SVN version there's also an init script that gets installed and makes sure the daemon starts automatically at startup.

About the XInput problem, that's in the todo list. Unfortunately my free time is limited, but I am planning to work on resolving that soon.

Posts: 127
Joined: Wed Mar 14, 2007 5:55 pm
Location: SF Bay Area, CA

Post by ettore » Thu Mar 20, 2008 11:45 am

Just wanted to add that Blender NDOF downloads WITH the plugin included are now also available at

Just unzip and it should be ready to go.
ettore pasquini
software engineer
3Dconnexion, inc.

Post Reply