and Fedora Core 7 - Where can I get it?

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Posts: 5
Joined: Tue Dec 25, 2007 6:00 pm
Contact: and Fedora Core 7 - Where can I get it?

Post by normaldotcom » Tue Dec 25, 2007 6:13 pm

I am running Fedora core 7 (x86_64) and I installed the linux x64 driver for the space navigator. The install went fine, but then I tried to start

Code: Select all

/etc/3DxWare/daemon/3dxsrv -d usb 
which returned

Code: Select all

/etc/3DxWare/daemon/3dxsrv: error while loading shared libraries: cannot open shared object file: No such file or directory

I have tried finding libMotif3 packages for fedora which provide this file, but I have been unable to find any. I also attempted something I saw on another website which involved copying to, which didn't do much of anything other than providing errors. Any help would be very nice!

Posts: 3565
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany

Post by UtaSH » Mon Jan 07, 2008 8:57 am

Hi normaldotcom,

this post can give hints how to solve this problem. Or if you already have OpenMotif installed but in a newer version just link it like this user did:

Code: Select all

ln -s
Uta Ludwig

Posts: 5
Joined: Thu Apr 10, 2008 12:38 pm

Post by daviddoria » Thu Sep 02, 2010 11:43 am

I tried creating that symblic link in /usr/lib/openmotif but even with that directory on my LD_LIBRARY_PATH it still did not work. When I made a link called in /usr/lib it worked correctly. Is there a reason the program looks only in /usr/lib instead of looking everywhere in LD_LIBRARY_PATH?



Post Reply