SpaceNavigator in VirtualBox

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

Post Reply
Posts: 3
Joined: Fri Feb 10, 2017 2:58 am

SpaceNavigator in VirtualBox

Post by ckevincrow » Fri Feb 10, 2017 3:45 am

I'd like to get this amazing little device configured for an intro CAD class, which is requiring that I use AutoDesk Inventor 2016. As I have a Linux laptop, I have configured a Windows 10 VirtualBox.

x86_64, i5 M520 @ 2.4Ghz
Linux Mint (Rosa = Ubuntu 14.04), 64 bit.
3dConnexion SpaceNavigator works flawlessly on host system.
VirtualBox Version 5.1.14 r112924 (Qt5.6.1), USB 3.0 xHCI
Running: Windows 10, 64 bit (no apparent problems in installation or operation)
3DxWare (in VirtualBox): 10.4.8 /

---I have reviewed prior posts and taken these actions:
vboxusers group added to my account (only account on system; I added vboxsf as well, for what it's worth).
Drivers on host OS not loaded before virtualbox starts or while it is running.
Several restarts of both VirtualBox and host.

There are no error messages anywhere. The Viewer and Demo in Windows simply do not respond to the device.

Any ideas what I might try next?

Posts: 534
Joined: Fri May 14, 2010 11:11 am

Re: SpaceNavigator in VirtualBox

Post by Barbara » Fri Feb 10, 2017 12:42 pm

Hello ckevincrow -

VirtualBox is not a configuration we do testing with or officially provide support - but if I were setting that up I would proceed as you have.

For the SpaceNavigator to be detected the USB port needs to be passed through to the virtual machine. The driver [3dxsrv] runs only when the device is detected.

Some of the VirtualBox docs show steps for creating a pass through of USB devices to VirtualBox. Once the USB is available there that should allow 3dxsrv to run then the Viewer and Demo become available.

Let us know if you would , once you have that running.
It is nice to know of setups beyond those we usually get a chance to work with.

Posts: 3
Joined: Fri Feb 10, 2017 2:58 am

Re: SpaceNavigator in VirtualBox

Post by ckevincrow » Fri Feb 10, 2017 6:10 pm


Simple VirtualBox user error - all I had to do was power up the Windows 10 VirtualBox, wait 30 seconds until "3Dconnexion Home" loads, then go to VirtualBox's menu, and select Devices-->USB-->3dConnexion SpaceNavigator [0431]. The test programs Viewer and Demo work fine. Nothing out of order but my knowledge of VirtualBox.

Thanks for the assistance despite the setup being uncommon. I wouldn't be surprised if you saw more of this as more people use Linux and software programs like Inventor refuse to create builds for it (I'll be sticking with my Linux ecosystem and a compatible CAD program following this class). Thanks to you at 3D Connexion for being a company that supports Linux.

In case it is of interest to you or assistance to others, here is what I drafted *before* I discovered the solution:


---In Linux host:
Tried full shutdown.
Reviewed list of processes to be sure spacenavd was not running, nor anything beginning with "3".
Double-checked that vboxusers is in user group.
Tried newgrp.

---In VirtualBox settings:
Double-checked that Settings->Enable USB Controller->USB 3.0 is checked (tried 1.0 as well).
No Device Filters are listed.

---In the Windows 10 virtualbox:
In device settings:
--Human Interface Devices:
[1.] 3dconnexion KMJ Emulator - Manufacturer: 3dconnexion, Location: Unknown, Device status: working properly, Driver Version:
[2.] HID-compliant game controller - Manufacturer: (Standard system devices), Location: on 3Dconnexion KMJ Emulator, Device status: working properly, Driver version: 10.0.14393.351.
[3.] USB Input Device - Manufacturer: (Standard system devices), Location: Port_#0001.Hub_#0001 [perhaps not related to 3dconnexion].
--Mice and other pointing devices
[1.] HID-compliant mouse - Manufacturer: Microsoft, Location: on 3Dconnexion KMJ Emulator, Device Status: working properly, Driver version: 10.0.14393.0.
[2.] HID-compliant mouse - Manufacturer: Microsoft, Location: on USB Input Device, Device Status: working properly, Driver Version: 10.0.14393.0.
[3.] Microsoft PS/2 Mouse - Manufacturer: Microsoft, Location: plugged into PS/2 mouse port, Device status: working properly, Driver version: 10.0.14393.0.

This is a complete list of the entries in Human Interface Devices and Mice and other pointing devices.

--Other devices
Base System Device - Manufacturer: Unknown, Location: PCI bus 0, device 4, function 0, Device: status: The drivers for this device are not installed (Code 28). There are no compatible drivers for this device. [no idea what this entry pertains to].

Note that since I am using a laptop, I am using a touchpad rather than a mouse [i.e., there is no mouse connected, and indeed no other USB devices of any kind].

--Settings->Connected Device Settings
Generic Non-PnP Monitor
USB Tablet [not sure what this refers to].

--Add a device --> "No devices found".
No other Connected Devices listed.


---Solution: see the top of this post! As an improvement, before powering up the Windows 10 VirtualBox virtual machine [i.e., opening the VirtualBox program but not starting the Windows 10 virtual machine], I went to the Windows 10 VirtualBox's Settings-->USB-->USB Device Filters-->Add and selected the 3D Connexion device. It is then auto-recognized when I start the Windows 10 VirtualBox.

Post Reply