MacOS 12.4 Cadmouse Enterprise stopped working

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Tue May 17, 2022 1:38 am

After installing the latest update to MacOS 12.4 my brand new CADmouse enterprise does nothing anymore...

Reinstalled the driver and re-booted everything with no succes.

Please help in how to fix this as soon as possible because I need it for my work in Onshape!

ngomes
Moderator
Moderator
Posts: 3093
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by ngomes » Tue May 17, 2022 9:52 am

Frank_Online wrote:
Tue May 17, 2022 1:38 am
After installing the latest update to MacOS 12.4 my brand new CADmouse enterprise does nothing anymore...

Reinstalled the driver and re-booted everything with no succes.

Please help in how to fix this as soon as possible because I need it for my work in Onshape!
I don't recognise that device name. Do you perhaps mean a "SpaceMouse Enterprise"?

Was everything working well before updating to macOS 12.4? Is this Onshape only or are the "demos" (System Preferences > 3Dconnexion > Tools tab) similarly affected?
Nuno Gomes

Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Tue Jul 19, 2022 4:34 am

Hi Gomes,

Every time when I leave my computer for some time the SpaceMouse Enterprise stops working. Launching 3DxNLserver and reboot the browser also doesn't work. So my main routine now is too reboot every time after I left my computer. This workflow is quite annoying. I'm using one of new Mac Studio's and this update was near instant when I receive the Mac. So hard to tell if the problem excited before. But I do have this problem for a long time now and used older drivers on my previous MacBook Pro to overcome this problem. Maybe it's something with 3DConnexion, Google Chrome and Onshape but it's a drag to work with now and hope for your help!

Greetings,

Frank

ngomes
Moderator
Moderator
Posts: 3093
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by ngomes » Tue Jul 19, 2022 4:46 am

Frank_Online wrote:
Tue Jul 19, 2022 4:34 am
Every time when I leave my computer for some time the SpaceMouse Enterprise stops working. Launching 3DxNLserver and reboot the browser also doesn't work.
When this happens again, please confirm if the "3DconnexionHelper" is still running. You can use Acivity Monitor to check this.

Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Wed Jul 20, 2022 5:18 am

Hi Gomes,

I checked the activity monitor this time and 3DconnexionHelper is active but 3DxNLserver is not running. Hope this helps in solving the problem.

Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Wed Jul 20, 2022 5:23 am

What I just found out is that:
--> when I relaunch 3DxNLserver
--> then quite the Chrome browser and relaunch
--> Move my mouse to a open Safari tab and make that one active
--> Go back to the Onshape tab in Chrome and click with my mouse
--> Then my SpaceMouse Enterprise works again and shows Onshape on the display.

ngomes
Moderator
Moderator
Posts: 3093
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by ngomes » Wed Jul 20, 2022 7:44 am

Frank_Online wrote:
Wed Jul 20, 2022 5:18 am
I checked the activity monitor this time and 3DconnexionHelper is active but 3DxNLserver is not running.
That indicates an issue with 3DxNLServer as it is not supposed to have terminated. If 3DxNLServer isn't running, then Onshape won't work with your SpaceMouse.

Using the "Console" applications, look for "Crash Reports" for 3DxNLServer. Then, right-click on a crash report and select "Reveal in Finder". Collect all the reports you wish to share in a single zip file. Then send the zip file to one of us in a private message using a Dropbox/OneDrive/GDrive/etc link. Please remember to post here that you have sent a private message and to whom it was addressed.

IMPORTANT: do not post links to crash reports in public web sites. Crash reports may contain sensitive information. In the case of 3Dconnexion software this does not really apply but do take care.

Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Tue Jul 26, 2022 4:20 am

Hi Gomes,

You should have had a private message by now with my crash reports!

Good luck and hope you will fix them

Frank

ngomes
Moderator
Moderator
Posts: 3093
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by ngomes » Tue Jul 26, 2022 6:31 am

Frank_Online wrote:
Tue Jul 26, 2022 4:20 am
You should have had a private message by now with my crash reports!
Thank you, Frank_Online. We got the new crash reports.

We will be reviewing these (in addition to those you shared with us back in January) to see if we can determine what is going on.

Frank_Online
Posts: 12
Joined: Fri Oct 29, 2021 5:23 am

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by Frank_Online » Wed Aug 10, 2022 5:27 am

ngomes wrote:
Tue Jul 26, 2022 6:31 am
Frank_Online wrote:
Tue Jul 26, 2022 4:20 am
You should have had a private message by now with my crash reports!
Thank you, Frank_Online. We got the new crash reports.

We will be reviewing these (in addition to those you shared with us back in January) to see if we can determine what is going on.
Hi Gomes, just installed the latest driver 10.7.4 (3493) and still the same problem. But the behavior is very constant now. After not using my computer for some minutes maybe max 15 to 30 minute of inactivity my 3D space mouse stops working. When I then relaunch 3DxNLServer and quit my browser and the relaunches, everything works again. Still not perfect for work but I hope this helps you to find this bug and fix it :) .

Cheers Frank

ngomes
Moderator
Moderator
Posts: 3093
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 12.4 Cadmouse Enterprise stopped working

Post by ngomes » Wed Aug 10, 2022 5:57 am

Frank_Online wrote:
Wed Aug 10, 2022 5:27 am
just installed the latest driver 10.7.4 (3493) and still the same problem.
Right. This is expected as we do not yet know what is going on.

Post Reply