macOS Big Sur - Beta Driver Available

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
garybart
Posts: 19
Joined: Thu May 06, 2021 6:41 pm

Re: macOS Big Sur - Beta Driver Available

Post by garybart » Thu Jul 22, 2021 2:30 pm

ngomes wrote:
Wed Jul 21, 2021 1:38 am
garybart wrote:
Tue Jul 20, 2021 3:26 pm
LMK what to do.
Please try the following procedure: open Terminal and run the following two commands.

First, terminate the running instance of "3DconnexionHelper" (the driver agent):

Code: Select all

sudo killall 3DconnexionHelper
Then, start the driver executable with the "-install" option:

Code: Select all

/Applications/3Dconnexion/3DconnexionHelper.app/Contents/MacOS/3DconnexionHelper -install
Let us know what is the output of the second command.

To relaunch the "3DconnexionHelper" program, simply reboot the system.
I have emailed the errors that resulted from that attempt (actually all of the output from that command in Terminal) to Abdul A yesterday, he replied and said he is checking with the dev team.

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Fri Jul 23, 2021 6:16 am

garybart wrote:
Thu Jul 22, 2021 2:30 pm
I have emailed the errors that resulted from that attempt (actually all of the output from that command in Terminal) to Abdul A yesterday,
We got the data, thanks. We're currently analysing it.

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Fri Jul 23, 2021 6:34 am

garybart wrote:
Thu Jul 22, 2021 2:30 pm
I have emailed the errors that resulted from that attempt (actually all of the output from that command in Terminal)
Here's what we have. The relevant error is the following trace:

Code: Select all

2021-07-21 20:40:42.462 3DconnexionHelper[9847:333118] -[TDxDEXTManager request:didFailWithError:] request <OSSystemExtensionActivationRequest: 0x13a023b30> didFailWithError The operation couldn’t be completed. (OSSystemExtensionErrorDomain error 10.)
Error code 10 is OSSystemExtensionErrorForbiddenBySystemPolicy.

As suspected, there is something on your system blocking the extension. Normally, users can go to the "Security & Privacy" pane in System Preferences to find an "Allow" button in the "General" tab. Once "allowed", the extension can run and the driver will begin to operate.

In your particular case, the "Allow" button isn't shown and we don't know why. Internally, there was a suggestion that there may be a problem with your macOS installation. In that case, you may want to consider resetting the PRAM and NVRAM (applies to Intel machines only; instructions here) and starting in Safe Mode to purge cached files (see here).

You may also want to check if you're running the latest version of macOS for your Mac.

slbaumgartner
Posts: 16
Joined: Wed May 31, 2017 2:15 pm

Re: macOS Big Sur - Beta Driver Available

Post by slbaumgartner » Sun Jul 25, 2021 11:31 am

I hadn't checked for a while so hadn't seen the July update until now. I notice that even on launch the 3DConnexionHelper is much smaller than it previously was. It will take a while of using it to see whether the footprint grows the way it was when I reported the memory leak.

But I have a different problem with the new driver: I can't turn off the LEDs. The checkbox on the properties has no effect!

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Mon Jul 26, 2021 2:44 am

slbaumgartner wrote:
Sun Jul 25, 2021 11:31 am
But I have a different problem with the new driver: I can't turn off the LEDs. The checkbox on the properties has no effect!
This is a known issue in the most recent "beta" build. We're tracking it as MAC-308 and expect to have it fixed in "beta 20".

Our apologies for the inconvenience. This is something we ought to have caught before the release of "beta 19".

garybart
Posts: 19
Joined: Thu May 06, 2021 6:41 pm

Re: macOS Big Sur - Beta Driver Available

Post by garybart » Mon Jul 26, 2021 12:28 pm

ngomes wrote:
Fri Jul 23, 2021 6:34 am
garybart wrote:
Thu Jul 22, 2021 2:30 pm
I have emailed the errors that resulted from that attempt (actually all of the output from that command in Terminal)
Here's what we have. The relevant error is the following trace:

Code: Select all

2021-07-21 20:40:42.462 3DconnexionHelper[9847:333118] -[TDxDEXTManager request:didFailWithError:] request <OSSystemExtensionActivationRequest: 0x13a023b30> didFailWithError The operation couldn’t be completed. (OSSystemExtensionErrorDomain error 10.)
Error code 10 is OSSystemExtensionErrorForbiddenBySystemPolicy.

As suspected, there is something on your system blocking the extension. Normally, users can go to the "Security & Privacy" pane in System Preferences to find an "Allow" button in the "General" tab. Once "allowed", the extension can run and the driver will begin to operate.

In your particular case, the "Allow" button isn't shown and we don't know why. Internally, there was a suggestion that there may be a problem with your macOS installation. In that case, you may want to consider resetting the PRAM and NVRAM (applies to Intel machines only; instructions here) and starting in Safe Mode to purge cached files (see here).

You may also want to check if you're running the latest version of macOS for your Mac.
going back to my IT department, this is getting to be the proverbial circle jerk, at this point.

garybart
Posts: 19
Joined: Thu May 06, 2021 6:41 pm

Re: macOS Big Sur - Beta Driver Available

Post by garybart » Mon Jul 26, 2021 12:28 pm

ngomes wrote:
Fri Jul 23, 2021 6:34 am
garybart wrote:
Thu Jul 22, 2021 2:30 pm
I have emailed the errors that resulted from that attempt (actually all of the output from that command in Terminal)
Here's what we have. The relevant error is the following trace:

Code: Select all

2021-07-21 20:40:42.462 3DconnexionHelper[9847:333118] -[TDxDEXTManager request:didFailWithError:] request <OSSystemExtensionActivationRequest: 0x13a023b30> didFailWithError The operation couldn’t be completed. (OSSystemExtensionErrorDomain error 10.)
Error code 10 is OSSystemExtensionErrorForbiddenBySystemPolicy.

As suspected, there is something on your system blocking the extension. Normally, users can go to the "Security & Privacy" pane in System Preferences to find an "Allow" button in the "General" tab. Once "allowed", the extension can run and the driver will begin to operate.

In your particular case, the "Allow" button isn't shown and we don't know why. Internally, there was a suggestion that there may be a problem with your macOS installation. In that case, you may want to consider resetting the PRAM and NVRAM (applies to Intel machines only; instructions here) and starting in Safe Mode to purge cached files (see here).

You may also want to check if you're running the latest version of macOS for your Mac.
going back to my IT department, this is getting to be the proverbial circle jerk, at this point.

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Mon Jul 26, 2021 12:45 pm

garybart wrote:
Mon Jul 26, 2021 12:28 pm
this is getting to be the proverbial circle jerk
We don't know what else we can try. From our analysis, your system is blocking the system extension. This is the expected behaviour until the user "allows" the system extension in the "Security & Privacy" pane in System Preferences.

What is unique about your case is that the "allow" button does not come up as expected.

Searching for additional information, we found this article. We also see that JamF has a whitelist process for kernel extensions but we found no references to system extensions.

nextr
Posts: 25
Joined: Sat Apr 10, 2021 1:50 pm

Re: macOS Big Sur - Beta Driver Available

Post by nextr » Tue Jul 27, 2021 6:25 am

I am still loving this Except, every couple hours or so while working in Zbrush the navigation knob just stops working.

All the other spacemouse functions still work (keys, shortcuts, etc). The navigation knob still works with the Trainer app.
The only way I have found to correct the problem is by restarting Zbrush.

Unplugging the space mouse, killing the space mouse app or reloading space mouse config settings do not have any impact.
I provided this info to pixologic support.

Any advice appreciated. Especially ideas to regain function without quitting and restarting zbrush (a bit of a pain).

Thank you,

Spacemouse pro
M1 Mac mini
Big Sur os 11.5
Space mouse driver Version 10.7.0 r3356 – Beta 19 – published on 19/07/2021)

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Tue Jul 27, 2021 7:04 am

nextr wrote:
Tue Jul 27, 2021 6:25 am
I am still loving this Except, every couple hours or so while working in Zbrush the navigation knob just stops working.

All the other spacemouse functions still work (keys, shortcuts, etc). The navigation knob still works with the Trainer app.
The only way I have found to correct the problem is by restarting Zbrush.

Unplugging the space mouse, killing the space mouse app or reloading space mouse config settings do not have any impact.
We will check this from our end. I don't think we had this reported yet (SpaceMouse stopping dead on ZBrush for macOS).

The fact that the buttons work indicates the driver is still running but the connection between it and the application is blocked somehow.

argiemza
Posts: 1
Joined: Tue Jul 27, 2021 8:02 am

Re: macOS Big Sur - Beta Driver Available

Post by argiemza » Tue Jul 27, 2021 8:07 am

Unfortunately, installation on the MAC OS is not working. I am getting the same issue as @garybart with extension.
I tested this on the 3 laptops: Macbook with the latest Big Sur OS 11.5.1 with Intel and M1 Chip. And also on the Macbook Air with M1 OS 11.4

The extension is not showing up in the "Security & Privacy" panel in System Preferences to find an "Allow" button in the "General" tab. Once "allowed", the extension can run and the driver will begin to operate.

It's a big problem because we cannot use your hardware with this.
I would recommend revisiting this firmware and run more tests

Thank you
Arek

nextr
Posts: 25
Joined: Sat Apr 10, 2021 1:50 pm

Re: macOS Big Sur - Beta Driver Available

Post by nextr » Tue Jul 27, 2021 8:28 am

We will check this from our end. I don't think we had this reported yet (SpaceMouse stopping dead on ZBrush for macOS).
Please hold off on this. It got exponentially worse this morning. Hanging after just a few minutes. So I tried other Zbrush files. I believe (hope) that it was due to a corrupted(?) z-zphere rigged subtool in my tool pallet. Once I got rid of that subtool it seems to be working again. At least the last hour or so.
I hope that was it and sorry if this was a false alarm.
Thanks

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Tue Jul 27, 2021 11:17 am

nextr wrote:
Tue Jul 27, 2021 8:28 am
Once I got rid of that subtool it seems to be working again. At least the last hour or so.
Good to know this seems to be limited to single file.
I hope that was it and sorry if this was a false alarm.
The behaviour as described originally did seem to indicate a problem: the application was still operational but not the 3D mouse. We're still investigating since this may reveal a weakness somewhere (client program and/or driver).

Can you share the problematic file?

ngomes
Moderator
Moderator
Posts: 2663
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: macOS Big Sur - Beta Driver Available

Post by ngomes » Tue Jul 27, 2021 11:23 am

argiemza wrote:
Tue Jul 27, 2021 8:07 am
The extension is not showing up in the "Security & Privacy" panel in System Preferences to find an "Allow" button in the "General" tab
At this point, our only suggestions is as described for user "garybart" (see here). We don't know why the system does not show the "Allow" button as required.
I would recommend revisiting this firmware and run more tests
This isn't an issue with the hardware (firmware) but with how the system is configured. We believe some systems are blocking the "allow" requests but we do not know why.

slbaumgartner
Posts: 16
Joined: Wed May 31, 2017 2:15 pm

Re: macOS Big Sur - Beta Driver Available

Post by slbaumgartner » Tue Jul 27, 2021 11:23 am

Immediately after a reboot, the new version of 3dConnexionHelper used only 9.6MB on my Mac, vs the 100 or more from the previous version. When working with SketchUp for a couple of days I saw this grow to 12.0MB. Then I was drawn away by other chores, and the computer sat idle without the SpaceNavigator even connected for two days. During that time the helper grew to 14.1MB.

So, although the footprint is now very small compared to previously and nowhere near consuming many GB as the previous, I can't know that there isn't still a leak, pin-hole sized though it may be. Is this small but steady growth expected? Why?

Post Reply