Google Earth Pro - Problem El Capitan & Space Mouse

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
Posts: 3
Joined: Fri Jan 08, 2016 11:04 am

Google Earth Pro - Problem El Capitan & Space Mouse

Post by squid1911 » Fri Jan 08, 2016 11:14 am

Need help w/ getting Space Mouse and Google earth Pro to work. Support provided the following

The issue is caused by Google delivering outdated 3Dconnexion libraries with Google Earth. We have already asked Google to correct this but the issue hasn't been solved yet. Please make sure to file a report with Google regarding this issue to make Google aware that its users need a fix for this problem.

A workaround for the problem would be to copy the files from the 3Dconnexion library to Google Earth’s library. We can provide instructions to do this, but note that you are doing this on your own responsibility.
In a terminal:
If you want to copy the file in a terminal this would be the command to do it:
cp -r /Library/Frameworks/3DconnexionClient.framework //
Note: may or may not be “/Applications”; it depends where Google Earth is located on your machine.

With the Finder:
If you copy the file within the Finder make sure NOT to move the framework out of its location: /Library/Frameworks/.
Open the GoogleEarth bundle (“Show package contents”) in the finder.
Copy /Library/Frameworks/3DconnexionClient.framework to // via drag

Not familiar on how to find the file in finder. Did a search for : Library/Frameworks/3DconnexionClient.framework and was unable to located.

Any help for dummies.... :D

Posts: 3655
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany

Re: Google Earth Pro - Problem El Capitan & Space Mouse

Post by UtaSH » Tue Jan 12, 2016 6:35 am

Hi sqiud1911,

as far as I know the search wouldn't find it because it belongs to the "kind of hidden" files. You should do the following: in the Finder use the menu "Go -> Go to Folder...". Note that you have to enter the full path including the leading / if applicable.

Posts: 2
Joined: Mon Jan 04, 2016 10:15 am

Re: Google Earth Pro - Problem El Capitan & Space Mouse

Post by Ivin » Sat Jan 30, 2016 12:08 pm

thanks this fixed it.

Post Reply