Use SpaceNavigator USB in combination with normal mouse

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
SavPaff
Posts: 1
Joined: Mon Mar 26, 2018 9:16 am

Use SpaceNavigator USB in combination with normal mouse

Post by SavPaff » Mon Mar 26, 2018 10:23 am

Hello,

I didn't know what to search for, so I am opening up a new topic. If there is some similar question already expressed I apologize.

So: I am trying to use the SpaceNavigator (left hand) and a normal mouse (right hand) to navigate in FreeCAD. Everything works fine as long as I use just one of both devices. As soon as I use both, as I am used to in CATIA V5 or Siemens NX, the focus jumps to an undefined position away from the object I am trying to examine.

Maybe this is a bug in FreeCad or it is some settings problem.

Does anyone have an idea how to fix this issue?

I am Using FreeCAD 0.16 64bit with Mac OS 10.13.3.

Thanks.

Sal

christophe
Moderator
Moderator
Posts: 29
Joined: Fri Sep 08, 2017 7:36 am
Contact:

Re: Use SpaceNavigator USB in combination with normal mouse

Post by christophe » Tue Mar 27, 2018 2:05 am

Hi SavPaff,

Unfortunately FreeCad is not a supported app see list here : https://www.3dconnexion.com/supported-s ... ware0.html

Still some devices may work, see https://www.freecadweb.org/wiki/index.p ... ut_devices they seem to have their own impletention done by a plugin spacenav http://spacenav.sourceforge.net/

The latest version of that plugin is from 2014, so it’s unlikely that our latest devices will work there. You may need to install an older version of the driver to get it working, see : https://www.3dconnexion.com/service/arc ... ivers.html

turbubestia
Posts: 1
Joined: Tue Jan 12, 2021 12:32 pm

Re: Use SpaceNavigator USB in combination with normal mouse

Post by turbubestia » Tue Jan 12, 2021 12:38 pm

I know this is an old post, but I just get here as I had the same problem. FreeCAD uses its own driver and can't work along with the 3DConextion properties. The solution is simple, with FreeCAD opened open the SpaceNavigator properties (make sure the title says FreeCAD), go to advance settings and disable all the contols. When they are enabled the zoom axis is sent to FreeCAD as the mouse wheel event chainging the zoom, so you will get the translation and zoom at the same time. So, use the FreeCAD Tools->Customize->Spaceball Motion GUI to configure your 3D mouse.

This works at least with 3DxWare 10.5.12, 3DxWinCore 17.5.12.15663, and FreeCAD 0.18 rev 4.

Post Reply