SpaceMouse Wireless loses connection with Vectorworks 2020

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
rjtiedeman
Posts: 17
Joined: Wed Jan 23, 2019 4:40 pm

SpaceMouse Wireless loses connection with Vectorworks 2020

Post by rjtiedeman » Fri May 01, 2020 3:36 pm

I am running Mac OS 10.15.4 and Vectorworks 2020 with 3Dconnection 3DXWare 10.6.5. While working with Vectorworks 2020 the SpaceMouse works fine for several hours but then the SpaceMouse Wireless stops responding. The only way to get the SpaceMouse Wireless Mac up is to restart my IMac.

The set up is:
SpaceMouse Wireless running (3DXWare 10.6.5 and 3DXMacCore v 1.1.4)
iMac Pro, 3 GHz 10-Core, 64 GB and Pro Vega 64 GPU.

Problem occurs with: Vectorworks 2020 SP3.1

:( :(

UtaSH
Moderator
Moderator
Posts: 3601
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceMouse Wireless loses connection with Vectorworks 2020

Post by UtaSH » Mon May 04, 2020 5:26 am

Hi rjtiedeman,

have you tested if the device itself still works in another application (e.g. the 3Dconnexion Viewer) once it stops working in Vectorworks?

if you open the 3Dconnexion properties in the System Prefs - does the driver still show the device?

rjtiedeman
Posts: 17
Joined: Wed Jan 23, 2019 4:40 pm

Re: SpaceMouse Wireless loses connection with Vectorworks 2020

Post by rjtiedeman » Mon May 04, 2020 8:51 am

Yes. I tested with trainer and it worked. Then later (after restarting again) after interruption I tested and nothing worked. This morning I have just started my iMac up after being off for 2 days and the Spacemouse wireless would not pair until I pulled the USB dongle. As of now it's back up working but something in the system is interrupting the driver connection. YES - I have deleted and reinstalled the driver.

I have a Logitech M705 mouse connected could that be an issue. Or is it OS 10.15.4 ?

Console crash report included (EXC_CRASH (SIGABRT)) Do you want the whole report? I checked several it's always the same.

Process: 3DxNLServer [675]
Path: /Applications/3Dconnexion/*/3DxNLServer.app/Contents/MacOS/3DxNLServer
Identifier: com.3dconnexion.3dxnlserver
Version: 1.3.4 (1.3.4.16675)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: 3DxNLServer [675]
User ID: 501

Date/Time: 2020-05-03 13:46:10.893 -0400
OS Version: Mac OS X 10.15.4 (19E287)
Report Version: 12
Bridge OS Version: 4.4 (17P4281)
Anonymous UUID: 63484DDD-0CE3-01DB-CA0A-B7AF641CA885

Sleep/Wake UUID: AA022A3D-E1B4-463E-913F-F3EF62418449

Time Awake Since Boot: 31000 seconds
Time Since Wake: 13 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called
terminating

UtaSH
Moderator
Moderator
Posts: 3601
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: SpaceMouse Wireless loses connection with Vectorworks 2020

Post by UtaSH » Mon May 11, 2020 2:50 am

Hi rjtiedeman,

can you please confirm: once the SpaceMouse Wireless stops working in Vektorworks you can still navigate in the 3Dconnexion Viewer.

Did you test if unplugging and re-plugging the Universal Receiver brings back the functionality of the device?
Did you test if the device would continue to work (after failing in Vectorworks) if you connect it with a cable?

Can you please test the following scenario: please remove any devices connected via a 2,4GHz connection. Switch them off (or maybe connect it with a cable). Then see if the situation improves.

rjtiedeman
Posts: 17
Joined: Wed Jan 23, 2019 4:40 pm

Re: SpaceMouse Wireless loses connection with Vectorworks 2020

Post by rjtiedeman » Thu May 21, 2020 8:30 am

UtaSh,
Hope all is well. What? "please remove any devices connected via a 2,4GHz connection." ?? My wireless is turned off. I do have a Logitech Mouse which has it's own USB dongle and software. But my wireless is shut off and my iMac Pro is connected directly by ethernet cable. I do have a Netgear Orbie wireless mesh hub in the room is that an issue? My house is full 2.4GHz and 5 GHz signals.

As of 10 am today the 3D Mouse is working. It normally takes several hours to stop completely . On 5/11 I sent in crash reports hope they will help. Since a new Mac OS 10.15.5 is coming soon I am hoping a new driver is also coming soon.

Regards,
Bob

Post Reply