iMac running Revit on a Windows 10 virtual machine

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
ctc
Posts: 4
Joined: Fri May 08, 2020 8:43 pm

iMac running Revit on a Windows 10 virtual machine

Post by ctc » Fri May 15, 2020 6:04 am

Has anyone had any luck making the spacemouse wireless work installed on an iMac running Revit on a Windows 10 virtual machine via Parallels? The first installation of the software failed, which is not a good sign. After uninstalling and reinstalling Revit was entirely unresponsive to the spacemouse.

swimbikego
Posts: 1
Joined: Fri Jun 19, 2020 11:58 am

Re: iMac running Revit on a Windows 10 virtual machine

Post by swimbikego » Fri Jun 19, 2020 12:05 pm

Hi -- I have spoken with both 3D Connexion and Parallels this week. 3D Connexions tech support said:

1. Spacemouse products are not supported in an virtual environment.
2. The Spacemouse running on the virtual windows is picking up the drivers on the host Mac.
3. To get it to work you will need to delete the drivers on the host Mac.

For me that is a non starter as I run Fusion360 an Sketchup on the Mac.

iMac 32Gb Ram, 4gb Video Ram
Virtual Windows 10 on Parallels with 12gb Ram assigned

UtaSH
Moderator
Moderator
Posts: 3601
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: iMac running Revit on a Windows 10 virtual machine

Post by UtaSH » Wed Jul 08, 2020 5:43 am

Hi swimbikego,

the SpaceMouse should work in a Parallels setup. It doesn't matter if you install a driver on the host or not. Just install the driver for Windows on your Parallels.

Then you have to select the device in the menu Devices -> USB & Bluetooth. Note - if you have a wireless device you have to select the Universal Receiver. Once you did this the SpaceMouse will disappear from your Mac. You can use the device only on one operating system at the same time. ;)

ctc
Posts: 4
Joined: Fri May 08, 2020 8:43 pm

Re: iMac running Revit on a Windows 10 virtual machine

Post by ctc » Wed Jul 08, 2020 6:07 am

I couldn’t get it to work and returned the product.

Post Reply