Space Navigator not recognized as a device

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
saakejam
Posts: 4
Joined: Tue Oct 09, 2018 5:38 am

Space Navigator not recognized as a device

Post by saakejam » Mon May 25, 2020 4:57 pm

2017 iMac - 32GB
Mac OS 10.15.4
3dX driver 10.6.5
Cad Mouse And Space Navigator

The system report shows both CadMouse and Space Navigator exist.

Space Navigator does not show up as a device. Only Cad Mouse.

Space Navigator acts like a mouse moving the cursor !

After Uninstalling/Reinstalling 3DX, with no firewall enabled, and checking the library folder everything is in place. As a matter of fact, all versions of SU had the plugin folder structure copied correctly.

Any help appreciated... I see many occurrences of these issues on the forums with 3DX.

UtaSH
Moderator
Moderator
Posts: 3601
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Space Navigator not recognized as a device

Post by UtaSH » Tue May 26, 2020 3:12 am

Hi saakejam,

did you follow the instructions from this FAQ?

ktabhalter
Posts: 1
Joined: Mon Jun 01, 2020 3:20 pm

Re: Space Navigator not recognized as a device

Post by ktabhalter » Mon Jun 01, 2020 3:24 pm

I am also having this problem. I am not getting a security prompt, nor is there an option to enter the number pad.
I know it worked a long time ago when I bought it, but now I can't use it.

Katkov
Posts: 3
Joined: Wed Jun 03, 2020 9:45 am
Contact:

Re: Space Navigator not recognized as a device

Post by Katkov » Wed Jun 03, 2020 9:49 am

I have the same problem with SpaceNavigator — it works like a mouse, 3Dconnexion software doesn't see it.
macOS Catalina 10.15.5

Katkov
Posts: 3
Joined: Wed Jun 03, 2020 9:45 am
Contact:

Re: Space Navigator not recognized as a device

Post by Katkov » Wed Jun 03, 2020 10:08 am

Solved it for my SpaceNavigator by these steps (I don't know, which of them are helped):
1. System Preferences → Security → Clicked to allow for 3Dconnexion
2. Installed plugins
3. Reset device (turn on with both buttons pressed)
4. Reboot
5. Reinstall 3DxWare
6. Reboot
7. It works

Post Reply