MacOS 11.00 (Big Sur)

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Mon Jan 04, 2021 1:07 pm

RVeldhuyzen wrote:
Mon Jan 04, 2021 12:41 pm
I'll just add another datapoint for the Maya issues.

I also connected it to the Macbook running Catalina, and the older driver, no issues there. No viewport glitching with 10.6.3.
So this is definitely an issue introduced driver side after 10.6.3.
All I know is when this starts happening I need to save my file and restart Maya, if I don't Maya crashes in a minute or so. Also, saving while the vertices jump around has no ill effect on the vertices. When reopening the file, everything looks perfectly fine.
We're seeing others reporting crashes in Maya. I suspect it is related to what you're seeing. We're trying to reproduce this in-house.
The Shift, Ctrl, etc buttons not working, but that is a known issue.
It's a known issue if you are trying to use a modifier with a mouse button or action. It should work fine in a keystroke action, say. We're also tracking a problem with key emulation with ZBrush. It would be helpful if you could share more details about what you're seeing.
The LEDs can only be on when it's connected through a wire. Wirelessly they turn on when I switch the SpaceMouse one, but they turn off 5 seconds later (both the blue ring and the green LED under the logo).
This is the expected behaviour. The LEDs will turn off automatically. This is to prevent draining the battery unnecessarily.
And the System Settings tab seems to think the SpaceMouse is running firmware 0.00 (both wired and wireless).
This is a known issue. The firmware version is not available over a wireless connection. The UI should state as much (or nothing at all) instead of "0.00" which is misleading.

RVeldhuyzen
Posts: 31
Joined: Sun Dec 19, 2010 11:46 am
Location: Veenendaal, The Netherlands

Re: MacOS 11.00 (Big Sur)

Post by RVeldhuyzen » Mon Jan 04, 2021 1:23 pm

ngomes wrote:
Mon Jan 04, 2021 1:07 pm
We're seeing others reporting crashes in Maya. I suspect it is related to what you're seeing. We're trying to reproduce this in-house.
Good to know I'm not the only one :)
It's a known issue if you are trying to use a modifier with a mouse button or action. It should work fine in a keystroke action, say. We're also tracking a problem with key emulation with ZBrush. It would be helpful if you could share more details about what you're seeing.
Oh, interesting, as a single keystroke outside of Maya (Finder, Mail, Safari, Pages, etc) it works, so pressing and holding SHIFT on the SpaceMouse and pressing a letter on the keyboard in any text field outside of Maya produces a capital letter as expected. But it doesn't in text fields in Maya.
Nor does Pressing shift and using the mouse do anything. In Maya holding SHIFT and moving an object (clicking and dragging the manipulator) duplicates the object to the new location, but that doesn't work. It just moves the original object like SHIFT was never pressed.
Esc, Ctrl and Alt also seem to work in basic Mac software, just not in Maya.
This is the expected behaviour. The LEDs will turn off automatically. This is to prevent draining the battery unnecessarily.
Okay, that makes sense :)
This is a known issue. The firmware version is not available over a wireless connection. The UI should state as much (or nothing at all) instead of "0.00" which is misleading.
Okay, good to know. Again, not really an issue, just something I noticed :)
It's time to roll the dice...

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Mon Jan 04, 2021 1:31 pm

RVeldhuyzen wrote:
Mon Jan 04, 2021 1:23 pm
Oh, interesting, as a single keystroke outside of Maya (Finder, Mail, Safari, Pages, etc) it works, so pressing and holding SHIFT on the SpaceMouse and pressing a letter on the keyboard in any text field outside of Maya produces a capital letter as expected. But it doesn't in text fields in Maya.
Nor does Pressing shift and using the mouse do anything. In Maya holding SHIFT and moving an object (clicking and dragging the manipulator) duplicates the object to the new location, but that doesn't work. It just moves the original object like SHIFT was never pressed.
Esc, Ctrl and Alt also seem to work in basic Mac software, just not in Maya.
Maya is based on Qt, just like ZBrush. Looks like this the common issue.

RVeldhuyzen
Posts: 31
Joined: Sun Dec 19, 2010 11:46 am
Location: Veenendaal, The Netherlands

Re: MacOS 11.00 (Big Sur)

Post by RVeldhuyzen » Mon Jan 04, 2021 1:37 pm

ngomes wrote:
Mon Jan 04, 2021 1:31 pm
Maya is based on Qt, just like ZBrush. Looks like this the common issue.
Okay, I hope the info helps you guys figure out a fix. I would love to use SHIFT with my pinky (don't mind the other buttons, they have been assigned to other functions, but I use SHIFT a lot :)
It's time to roll the dice...

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Mon Jan 04, 2021 1:41 pm

RVeldhuyzen wrote:
Mon Jan 04, 2021 1:37 pm
Okay, I hope the info helps you guys figure out a fix.
Well, we currently believe we need to deploy a "DriverKit extension" (a "dext") to emulate keyboard modifiers if we want to match the experience if our driver in macOS 10.15 and older.

And that's what we did not manage to do in the 14 to 15 months or so after WWDC 2019.

We hope to return to that work soon. There were some interesting developments just before macOS 11 came out.

bitsplusatoms
Posts: 3
Joined: Mon Jan 18, 2021 12:38 pm

Re: MacOS 11.00 (Big Sur)

Post by bitsplusatoms » Wed Jan 27, 2021 10:24 am

ngomes wrote:
Mon Jan 04, 2021 1:41 pm
RVeldhuyzen wrote:
Mon Jan 04, 2021 1:37 pm
Okay, I hope the info helps you guys figure out a fix.
Well, we currently believe we need to deploy a "DriverKit extension" (a "dext") to emulate keyboard modifiers if we want to match the experience if our driver in macOS 10.15 and older.

And that's what we did not manage to do in the 14 to 15 months or so after WWDC 2019.

We hope to return to that work soon. There were some interesting developments just before macOS 11 came out.
@ngomes, can you say definitively that there will be support for Apple Silicon? Do you know the time frame? I just bought a second space mouse - this one for use with an M1-based Mac. It was my mistake not to check whether it was supported before doing so. I just want to know whether I should return it (the space mouse, not the Mac), or hold out a little longer. Thanks.

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Thu Jan 28, 2021 11:02 am

bitsplusatoms wrote:
Wed Jan 27, 2021 10:24 am
@ngomes, can you say definitively that there will be support for Apple Silicon? Do you know the time frame? I just bought a second space mouse - this one for use with an M1-based Mac.
We're working on putting together a "universal" build of the driver (native code for both Intel and the ARM).

At this stage, we don't yet have a timeframe. We should know more later next week.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Thu Jan 28, 2021 1:07 pm

bitsplusatoms wrote:
Wed Jan 27, 2021 10:24 am
@ngomes, can you say definitively that there will be support for Apple Silicon?
I am on a M1 Mac Mini only now, since a week or so.

So far I see no difference in 3D Connexion Devices behavior between
Intel Mac and Apple Silicon Mac so far.
What does not work on Intel does also not work on my M1 Mini.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Mon Feb 08, 2021 1:36 pm

With newest Beta Driver (V12 ?)

At least on Apple Silicon,
My side Buttons of Space Navigator and CADMouse original USB don't work,
at least in Safari and Firefox.

Space Navigator buttons seem work in Vectorworks
(but strange in Bricscad)
while CADMouse Side Buttons seem to no more work in Vectorworks and
Bricscad.

I think that last Update is a big regression for original CADMouse USB
users under Big Sur on M1 Macs.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Mon Feb 08, 2021 1:59 pm

Examined a bit more.

It is not that those Side Buttons are dead,
it seems that they do not work with "Keystroke" setups anymore !
Looks like they work for, e.g. Vectorworks, when applying a
"Application Command" instead of a Keystroke, if delivered by App Vendor


Aabout 90% of any of my 3DConnexion assignments are - by Keystroke - though.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Mon Feb 08, 2021 2:06 pm

And what I notice since installing these Big Sur Beta Drivers,
no matter if Intel or M1 Macs,is that certain standard System Short Cut
key combinations do no more work reliably for me.
Like CMD+C and CMD+V do no more work in Apps like Safari at all but
still work in Finder or 3D Apps.
And things like CMD+A, to select all, e.g. in Mail mostly for the first try
will do something like "jump to last line" and need a second try that will
finally Select All mails to delete and such things.

So for me it looks a bit like 3DConnection Driver somehow negatively influences
the functionality of, especially, the CMD key.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Mon Feb 08, 2021 3:15 pm

Looks like Makros don't work for CADMouse anymore either (Bricscad)

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Tue Feb 09, 2021 1:12 am

zoomer wrote:
Mon Feb 08, 2021 2:06 pm
So for me it looks a bit like 3DConnection Driver somehow negatively influences
the functionality of, especially, the CMD key.
You seems to be looking at a known issue: modifier key emulation in macOS 11 has limitations. We're working to restore the same experience as available in macOS 10.15 and older but it will take time. We believe deploying a DriverKit extension to create virtual keyboard (as done with a kernel extension in the older macOS versions) will resolve these complaints but it is not a straightforward forward as we were unable to deploy such a solution before macOS 11 was released.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Tue Feb 09, 2021 4:42 am

Hi ngomes,

do you mean that the modifier keys will currently not run for 3DConnexion devices only,
that would not be such an issue.

I meant that for me, it looks like the 3DConnecxon drivers would irritate the system wide
use of CMD key. Like when I just hit CMD+C/V on my Apple Keyboard.
Either the Driver itself or at least if any 3DConnexion device plugged in (?)

Sometimes CMD key works as expected, or for an amount of time, most times
it get ignored in Safari.

sometimes CMD+A in Mail just selects all mails in the trash folder, but sometimes
CMD+A just jumps the list to the lowest entry and selects it. A second attempt
will again work.

It feels like CMD is a bit more reliable when you press it long before pressing
the secondary keys or doing it twice.

And it is definitely App dependent, which CMD+key combination works or fails
regularly in which App.
But it is always in combination with CMD, not with SHIFT or ALT.

I already searched for wrong shortcut entries in App and Keyboard settings
but I do not find anything wrong there. Also it does work from time to time
as it should. But not reliable

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Tue Feb 09, 2021 4:52 am

Or I often tried to copy an URL in Safari to paste into Firefox and
the CMD was ignored - instead CMD+C replaced my URL bei a "c"

Currently it works pretty much as expected for me though.
Will try if it will work a whole day that way when I unplug any 3DConnexion device.

Post Reply