MacOS 11.00 (Big Sur)

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Thu Feb 25, 2021 4:24 pm

Don't know what is wrong with 3DCon driver and Apple CMD key.

Usually CADMouse and button assignments with CMD Modifier work.
But Yesterday I had a whole day to manually press CMD on Keyboard because
CMD in CADMouse keystroke assignments was ignored.
(At that time, it also didn't work for similar commands in Enterprise)

AFAIK that did not better, that the last CadMouse keystroke using CMD Modifier,
will prevent Mac OS and keyboard from using the next CMD Modifier, and will
need another press of CMD to enable a Short Cut.


BTW
Now, since latest driver update ?, Enterprise will prevent my M1 Mini from
going into Sleep !
Mac > go to sleep, Monitor gets dark, Enterprise display goes dark, Enterprise Display
awakes, M1 Mini and Monitor awakes ....

briwil
Posts: 4
Joined: Tue Feb 23, 2021 10:44 am

Re: MacOS 11.00 (Big Sur)

Post by briwil » Thu Feb 25, 2021 10:01 pm

zoomer wrote:
Thu Feb 25, 2021 4:24 pm
Don't know what is wrong with 3DCon driver and Apple CMD key.

Usually CADMouse and button assignments with CMD Modifier work.
But Yesterday I had a whole day to manually press CMD on Keyboard because
CMD in CADMouse keystroke assignments was ignored.
(At that time, it also didn't work for similar commands in Enterprise)

AFAIK that did not better, that the last CadMouse keystroke using CMD Modifier,
will prevent Mac OS and keyboard from using the next CMD Modifier, and will
need another press of CMD to enable a Short Cut.


BTW
Now, since latest driver update ?, Enterprise will prevent my M1 Mini from
going into Sleep !
Mac > go to sleep, Monitor gets dark, Enterprise display goes dark, Enterprise Display
awakes, M1 Mini and Monitor awakes ....
Are you sure this is 3DConnexion-related?

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Fri Feb 26, 2021 5:34 am

Preventing from sleep ?

I think yes.
If I unplug my Enterprise
(CADMouse still plugged in)
I can put my M1 Mini to sleep as usual.

If I plug Enterprise back in,
Mini will go to sleep and immediately awake again.

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Fri Feb 26, 2021 5:49 am

zoomer wrote:
Fri Feb 26, 2021 5:34 am
If I plug Enterprise back in,
Mini will go to sleep and immediately awake again.
This looks like your SpaceMouse Enterprise is constantly sending data. Try running one of demos (see the "About" tab in the "3Dconnexion" pane in System Preferences). Check if there is data being displayed even if you're not touching the sensor cap.

This "drifting" can occur if the device is left for an extended period of time with the sensor pressing against something. Once released, the sensor springs can take quite some time to return to the relaxed position.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Fri Feb 26, 2021 5:59 am

Unfortunately no.
No I had already calibrated when it occured for the first time.
I see no unwanted data sent at all.
Sensor cab works beautifully in demos.

But tried again.
Apfel > Ruhezustand.

Monitor + Enterprise Display go dark
Enterprise Display goes on again,
Mini awakes

beurlej
Posts: 1
Joined: Sat Jul 06, 2019 8:08 pm

Re: MacOS 11.00 (Big Sur)

Post by beurlej » Tue Mar 02, 2021 8:36 pm

Any update on when a non beta version of 3DC is supported in Big Sur?

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Wed Mar 03, 2021 8:58 am

Another thing,
when I plug in 2 external SSDs to a separate USB Hub on the
second USB 3 slot of the Mini,
CADMouse and Enterprise on Slot1 Hub will no more work.

Even after unplugging SSDs, reconnecting CADMouse or Enterprise will
no more work until the next Reboot.
So for me it looks like the Driver crashed in that case.


And several system sleep periods can sometimes lead to CADMouse
ignoring/forgetting the CMD key in such Keystroke assignments.
While those Keystrokes will still work when I hold the CMD on
my keyboard.

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Wed Mar 03, 2021 9:47 am

zoomer wrote:
Wed Mar 03, 2021 8:58 am
Another thing,
when I plug in 2 external SSDs to a separate USB Hub on the
second USB 3 slot of the Mini,
CADMouse and Enterprise on Slot1 Hub will no more work.

Even after unplugging SSDs, reconnecting CADMouse or Enterprise will
no more work until the next Reboot.
So for me it looks like the Driver crashed in that case.
USB hubs are notoriously unreliable, especially so when drawing a significant amount power.

After reconnecting the SpaceMouse Enterprise, check in Activity Monitor if the "3DconnexionHelper" process is still running. If it is not running, then we have a driver issue we need to look at as it probably crashed. Then go to System Preferences and open the 3Dconnexion pane. This will restart the daemon process and should, at least, avoid having to reboot.
And several system sleep periods can sometimes lead to CADMouse
ignoring/forgetting the CMD key in such Keystroke assignments.
While those Keystrokes will still work when I hold the CMD on
my keyboard.
As mentioned separately, we have a bug in the handling of modifier key. The bug (MAC-290) is marked as resolved and the fix will be included in next beta.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Wed Mar 03, 2021 10:43 am

I tried 3DConn Pane.
It did not allow to edit my devices.

Will look at it again.

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Wed Mar 03, 2021 10:49 am

zoomer wrote:
Wed Mar 03, 2021 10:43 am
I tried 3DConn Pane.
It did not allow to edit my devices.
No, it wouldn't if the devices cannot be accessed which can happen if the power drawn by the system exceeds some limit (whatever that may be). Opening the "3Dconnexion" pane will ensure the daemon is started. You can check if the "3DconnexionHelper" daemon is up and running by checking it in the processes list in Activity Monitor.

zoomer
Posts: 158
Joined: Sat Aug 20, 2016 8:53 am

Re: MacOS 11.00 (Big Sur)

Post by zoomer » Wed Mar 03, 2021 1:52 pm

Yes, it is all strange and my observations not very helpful.

That Hub has a power supply with even a (unused) USB charging slot.
And usually it runs only CADMouse, Apple USB keyboard and (3D Navigator)
or Enterprise! in that case, fine.
(with Enterprise plugged off, at that time too, as preventing from sleep ...
Also Enterprise may be likely the biggest power consumer and usually
very picky, like renouncing to work in the apple keyboard Hub, because
of moaning about getting more powerby USB)
So CADMouse should be powered sufficient.

Replugging CADMouse, removing power and/or unplugging the Hub in between
did not work to make CADMouse working.
When adding Enterprise it showed the same blinking on my USB Hub's LED.

Therefore I thought a Driver Crash is likely.
But maybe on my M1 Mini, the driver was still running - so not restarting by
3DConnexion pane in Mac Settings - but temporarily dement or so ....

marcarch
Posts: 84
Joined: Mon Oct 22, 2018 9:41 am

Re: MacOS 11.00 (Big Sur)

Post by marcarch » Thu Mar 18, 2021 1:50 am

This is the issue I was referring to time ago. It happens in Safari and it's Smart scroll related.
https://drive.google.com/file/d/1xTEM5o ... sp=sharing

- one side note about Smart scroll: I tried to use the CMW on an iPad, it works really well, except for the scrolling. Smart scroll seems enabled by default, is it probably a CMW firmware setting?

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Thu Mar 18, 2021 1:57 am

marcarch wrote:
Thu Mar 18, 2021 1:50 am
This is the issue I was referring to time ago. It happens in Safari and it's Smart scroll related.
https://drive.google.com/file/d/1xTEM5o ... sp=sharing
Not sure I follow. Are you referring to sudden move to the top? That might be what's expected if you flick the wheel (which will active Smart Scrolling).

It may also be something like wheel resolution. Some applications will respond differently to high or regular resolution data.
- one side note about Smart scroll: I tried to use the CMW on an iPad, it works really well, except for the scrolling. Smart scroll seems enabled by default, is it probably a CMW firmware setting?
It's a firmware feature, yes. I can't recall from the top of my head but I believe it's enabled by default.

marcarch
Posts: 84
Joined: Mon Oct 22, 2018 9:41 am

Re: MacOS 11.00 (Big Sur)

Post by marcarch » Thu Mar 18, 2021 3:00 am

ngomes wrote:
Thu Mar 18, 2021 1:57 am
Not sure I follow. Are you referring to sudden move to the top? That might be what's expected if you flick the wheel (which will active Smart Scrolling).
It's about moving away from the window where I triggered Smart scroll, the Smart scroll keeps scrolling:
- I (smart) scroll the safari window-webpage up (the CMW smart scrolls as expected);
- then I move the cursor on Safari tabs bar, the mouse keeps scrolling through tabs (this is unexpected and unwanted).

ngomes
Moderator
Moderator
Posts: 2493
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: MacOS 11.00 (Big Sur)

Post by ngomes » Thu Mar 18, 2021 4:49 am

marcarch wrote:
Thu Mar 18, 2021 3:00 am
- then I move the cursor on Safari tabs bar, the mouse keeps scrolling through tabs (this is unexpected and unwanted).
Is this something new in macOS 11 (a regression)?

If you move the wheel on the opposite direction (even if only slightly) or press a button, the dynamic scroll should stop.

Post Reply