1.0.1 QT Component Causing Numerous Issues

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
amahler
Posts: 4
Joined: Tue Mar 06, 2007 10:51 am

1.0.1 QT Component Causing Numerous Issues

Post by amahler » Thu Mar 08, 2007 10:35 pm

Hello!

I have QT 7.1.5 on my machine and had recently added the 1.0.1 beta of the driver with its QT component for QTVR navigation. A day or so later, I happened to be launching PTMac (panorama stitcher) and it would die instantly everytime I tried to add a JPEG, thus rendering the app useless.

The PTMac crash log showed a QT-related thread blowing sky high.

At first I thought it might be QT 7.1.5, but that was dispelled pretty quickly when comparing against another machine. That's when I remembered the new beta driver, spotted the QT component and decided to remove it as a test. Voila - PTMac problem solved.

This evening I've also come to realize that the presence of the QT component also prevents RealViz Stitcher 5.0's installer from working. It dies after admin password authentication. Once again, removing the QT component that came with the 1.0.1 driver resolves the issue.

I can provide you with crash logs from PTMac if it's helpful to you in debugging.

- Aaron

flomotan
Moderator
Moderator
Posts: 287
Joined: Mon Jan 08, 2007 3:37 pm

Post by flomotan » Thu Mar 08, 2007 10:52 pm

Hi Aaron,

Yes, please send us the crash logs. I'll send you a separate note on how to do this.

Thanks for reporting this issue

ettore
Moderator
Moderator
Posts: 127
Joined: Wed Mar 14, 2007 5:55 pm
Location: SF Bay Area, CA
Contact:

Post by ettore » Wed Mar 14, 2007 6:06 pm

Hi amahler, I am the engineer who coded the plugin. I worked on your bug today and fixed the crash. Next version should have this fix. Thanks.

amahler
Posts: 4
Joined: Tue Mar 06, 2007 10:51 am

Post by amahler » Wed Mar 14, 2007 6:37 pm

Great to hear. I look forward to the next update and thanks for the quick focus on the issue. :)

I hope the logs were useful...

- Aaron

ettore
Moderator
Moderator
Posts: 127
Joined: Wed Mar 14, 2007 5:55 pm
Location: SF Bay Area, CA
Contact:

Post by ettore » Wed Mar 14, 2007 8:21 pm

I forgot to mention: I also tried to install RealViz Stitcher 5.5 (trial version available from RealViz website) and it installed fine with the fixed 3DxQuickTime component.

PS.
Yes, logs are always useful :wink: Thanks

Akila Ninomiya@QTVR Diary
Posts: 2
Joined: Thu Jan 18, 2007 5:29 pm
Location: Kyoto,Japan
Contact:

same problem?

Post by Akila Ninomiya@QTVR Diary » Sun Mar 18, 2007 12:54 am

Thought it's the same problem, and post now.
It shut down suddenly by starting CubicConverter to do QTVR in authoring.
QTVR might not be able to be controlled with SpaceNavigator after the version up to 7.1.5, then 3dxware 1.0.1 has been uninstalled the other day.

Please release the bug fix version early.

ettore
Moderator
Moderator
Posts: 127
Joined: Wed Mar 14, 2007 5:55 pm
Location: SF Bay Area, CA
Contact:

Re: same problem?

Post by ettore » Wed Mar 21, 2007 2:24 pm

Akila Ninomiya@QTVR Diary wrote:Thought it's the same problem, and post now.
It shut down suddenly by starting CubicConverter to do QTVR in authoring.
QTVR might not be able to be controlled with SpaceNavigator after the version up to 7.1.5, then 3dxware 1.0.1 has been uninstalled the other day.
I downloaded the trial 2.2.1 version and I didn't see any problems after my fix.

I am not too familiar with CubicConverter, so let me know if this is not the scenario you were thinking at: I opened up the app --> Conversion tab --> click on QTVR button --> imported QTVR movie --> clicked Convert button. No crashes or weird behaviors noticed.

Post Reply