OSX Maya 2013 64bit w/ SpaceNavigator

Questions and answers about 3Dconnexion devices on macOS.

Moderator: Moderators

Post Reply
andrewjarvis
Posts: 3
Joined: Sat Jan 25, 2014 1:19 pm

OSX Maya 2013 64bit w/ SpaceNavigator

Post by andrewjarvis » Sat Jan 25, 2014 1:25 pm

I've updated the driver, installed the software and the Maya plugin, but when I click to load the plugin in the Plugin Window I get the following error:

"// Error: does not match the current architecture (3DxMayaResources)"

Does that just mean my Navigator is too old to be supported on the latest Maya?

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: OSX Maya 2013 64bit w/ SpaceNavigator

Post by UtaSH » Mon Jan 27, 2014 6:14 am

Hello andrewjarvis,

the message doesn't have to do with the attached 3D mouse, but more with your operating system. Which version of OS X do you have?

andrewjarvis
Posts: 3
Joined: Sat Jan 25, 2014 1:19 pm

Re: OSX Maya 2013 64bit w/ SpaceNavigator

Post by andrewjarvis » Mon Jan 27, 2014 8:43 am

OSX 10.9.1 (Mavericks) - Build 13B42

crobl
Moderator
Moderator
Posts: 131
Joined: Mon Feb 26, 2007 8:34 am
Location: Freiham, Germany

Re: OSX Maya 2013 64bit w/ SpaceNavigator

Post by crobl » Tue Jan 28, 2014 1:15 am

Hi andrewjarvis,

3DxMayaResources is actually not a plugin for Maya. It is a resource bundle supporting 3DxMaya.
There is no need to load 3DxMayaResources via the Plugin Window, nor will it work (as you experienced).

3DxMaya on the other hand can be loaded and actually should be automatically loaded after installation.
If it is disabled for some reason, you may of course enabled it in the Plugin Window!

I hope I could shed some light on this. Please let me know if you have further questions!

Regards,

Christian Robl

Post Reply