3DxWare not loading in 2018!

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 15, 2020 4:33 am

I have the same problem: SpaceNavigator is not loading on boot, can't get it to work, lED's are off.

Driver Version is 3DxWare64_v10-6-7_r3198.

Please advise!

Thanks

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 15, 2020 5:20 am

I completely eradicated the driver by uninstalling it and manually removing any leftovers, rebooted, installed the latest driver, plugged the SpaceNavigator in -- no avail.

I get all sorts of errors when trying to start things from the "Home" Dialog Window:
Image

...namely the following:
Image
Image
Image


Please advise what to do to fix this.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 15, 2020 5:30 am

The SpaceNavigator is also present and working according to Windows Device Manager:

Image

:?: :?: :?:

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 15, 2020 5:36 am

OK so I simply installed the driver again (without uninstalling it first), this time with Admin privileges, AND with the SpaceNavigator plugged in (other than what is officially recommended).

IT THEN INSTANTLY WORKED.

Thanks for explaining why this would happen.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 19, 2020 1:40 am

OK the SpaceNavigator stopped working again, this time without any errors.

LED's are off, however the SpaceNavigator is present in Device Manager.

What could be wrong here?

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 19, 2020 1:48 am

PS: actually this error now is back as well!

Image

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 19, 2020 4:33 am

And it's not a hardware failure either, since the SpaceNavigator works perfectly on another PC -- there with the 10.6.3 driver version.

The PC where it doesn't work has the latest 10.6.7 drivers.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2020

Post by David.P » Tue May 19, 2020 2:13 pm

OK it works again flawlessly after downgrading the driver to v10.6.3.

Thanks for looking into the obviously buggy driver v10.6.7.

And thanks for letting me have that disenchanting monologue here

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Fri May 22, 2020 2:53 am

Well one day later, and the same error is back, while the SpaceNavigator is sitting there again as a paperweight:

Image

It would be kind of you guys at Logitech/3DConnexion to at least let us users know that someone of you is still here by replying to this thread.

UtaSH
Moderator
Moderator
Posts: 3565
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: 3DxWare not loading in 2018!

Post by UtaSH » Tue May 26, 2020 2:43 am

Hi David.P,

the error that you get doesn't seem to be related to our driver. CRYPT32.dll is a DLL from Microsoft.

We haven't seen this error before. Could it be that your Windows installation has a failure?

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 26, 2020 7:58 am

Thanks Uta.

After uninstalling the SpaceNavigator driver and reinstalling the latest driver version v10.6.7, I don't get that crypt32.dll error anymore.

Also, I checked my Windows installation and it is error-free.

If I unplug the SpaceNavigator and re-plug it into anoter USB-port, it shows up as ready to use.

Also, the SpaceNavigator shows up properly in Windows Device Manager.

However, it still sits there without LEDs runnning and not working.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 26, 2020 8:10 am

OK so I ran 3dxrepair.exe from C:\Program Files\3Dconnexion\3DxWare\3DxWinCore.

After a reboot, SpaceNavigator seems to work now (fingers crossed).

I believe it's odd that running the 3dxrepair.exe tool almost never seems to be recommended around this forum. This seems to be a useful and powerful tool (fingers crossed again).

jwick
Moderator
Moderator
Posts: 2696
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: 3DxWare not loading in 2018!

Post by jwick » Tue May 26, 2020 8:19 am

If it fails again, turn on driver logging (3Dx systray icon). If the driver is having a hard time accessing the device, it might log a message about it. Your system drivers seem to be installed correctly.

If the LEDs don't work, it could be a power issue. There have been reports in the past about machines powering down USB ports. I haven't heard about it in quite some time though.

I can also send you a test program that will test the raw hardware.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Tue May 26, 2020 10:15 am

Thank you, will do so and report back.

David.P
Posts: 59
Joined: Mon Aug 04, 2008 3:36 am

Re: 3DxWare not loading in 2018!

Post by David.P » Thu May 28, 2020 6:51 am

Hi all,

currently, my SpaceNavigator lights up and is usable after opening an assembly in Parametric's Creo View CAD Viewer.

Is that the intended behavior?

I seem to remember that SpaceNavigator would light up just after booting up the PC.

Thank you

Post Reply