Z Rotation Conflict with Thrustmaster Throttle

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Posts: 1
Joined: Fri May 07, 2021 1:58 am

Z Rotation Conflict with Thrustmaster Throttle

Post by MAS42 » Fri May 07, 2021 2:48 am

Hi All,

I have a Thrustmaster Warthog Throttle and recently bought a spacemouse. Since then the left throttle (Z rotation) isn't working properly (off until maximum then full on). I can't be 100% sure but I suspect it's linked to the spacemouse which also uses Z rotation. I've tried removing/uninstalling the spacemouse but this doesn't seem to have any effect.

Does anyone know how I can temporarily disable the spacemouse to see if this really is the issue? I've tried the following but this doesn't work for me either https://www.revit.news/2016/10/how-to-d ... ntrollers/

Many thanks

Posts: 2879
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA

Re: Z Rotation Conflict with Thrustmaster Throttle

Post by jwick » Fri May 07, 2021 2:59 am

Uninstall 3DxWare to disable it. You can also use the device manager (as in that post) to disable parts of it.

The problem is probably in the game. It's a rare game that supports more than one joystick device correctly. They often just find the first one and run with it. And assume it is a popular joystick they've seen before--our joystick emulator may not match up with that perfectly.

We are also starting to see games open the native device, not using the joystick emulator. It's not so easy to interpret the HID descriptors. They often get it wrong. It seems that even Microsoft gets it wrong. Sometimes there is a game configuration panel that allows you to fix it (e.g. in Flight Simulator).

If it is the latter, just unplugging the hardware device should fix it. If it is the emulator, it would have to be uninstalled.

Post Reply