Spacemouse axis's stop working in Revit when I unplug other USB devices

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Orchards92@gmail.com
Posts: 8
Joined: Tue Oct 26, 2021 7:24 am

Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by Orchards92@gmail.com » Tue Oct 26, 2021 7:34 am

So I've pretty much always had this issue, I've updated everting and am even tried completely separate computes. This only happens with Revit and no other programs but if I disconnect other USB devices or a monitor then all the axis stop working in Revit. The buttons on the sides still work and everything still works as it should in other programs like Navisworks but no matterwhat i do they wont work in Revit again until I restart Revit. Normally its not an issue, but it is a pain when I take my laptop into a meeting and I need to close down Revit and reopen the model which can take forever sometimes.

Has anyone else had this issue with Revit? I'm using Revit 2020 and SpaceMouse Wireless 3DX-700066 Wireless 3D.

aalsalihi
Posts: 128
Joined: Mon Apr 15, 2019 9:14 am

Re: Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by aalsalihi » Tue Oct 26, 2021 9:09 am

Hi Orchards92@gmail.com,

Does this issue happens with the receiver? or when you plugged in via cable?
Have you tired instead to Stop and Start the driver?

1. Click on the windows logo in the bottom left.

2. In the listed programs, look for the 3Dconnexion folder. Click on it.

3. Scroll down. There will be a start and stop driver button. It also may be listed as Start/Stop 3DxWare. Select the Stop Driver (3DxWare) and give that about 10 seconds to stop the driver.

4. Once that is done, Right click on the Start Driver (3DxWare).

5. Test for the issue.

Regards,
Abdul. A

Orchards92@gmail.com
Posts: 8
Joined: Tue Oct 26, 2021 7:24 am

Re: Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by Orchards92@gmail.com » Wed Oct 27, 2021 3:36 am

Ok I just tested both but neither helped. Its odd when I disconnect my monitor then I try the 3d mouse it works for about 1 second then it stops.

aalsalihi
Posts: 128
Joined: Mon Apr 15, 2019 9:14 am

Re: Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by aalsalihi » Thu Oct 28, 2021 7:47 am

Hi ards92@gmail.com ,

Does the device stops working in Revit only? or in another applications as well?
I would recommend doing cleaning for driver configurations by following this FAQ here https://3dconnexion.com/us/support/faq/ ... r-windows/

Regards,
Abdul. A

Orchards92@gmail.com
Posts: 8
Joined: Tue Oct 26, 2021 7:24 am

Re: Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by Orchards92@gmail.com » Sat Oct 30, 2021 12:30 pm

ok I went through all those steps and I still get the same result, once I unplug any other USB device all 6 axis stop responding but the side buttons still work.

This is only in Revit and never in any other programs.

Orchards92@gmail.com
Posts: 8
Joined: Tue Oct 26, 2021 7:24 am

Re: Spacemouse axis's stop working in Revit when I unplug other USB devices

Post by Orchards92@gmail.com » Thu Nov 04, 2021 6:53 am

So this is only in Revit.

So I just went through the process of cleaning all the drivers and doing a complete fresh install and it didnt help. I have 2 other co workers that are using the same Revit and 3dmouse and have the exact same problem, so I think its an actual issue and not just a random fluke on my end.

Post Reply