Remote Desktop use of local Space Navigator

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
dlouiselle
Posts: 4
Joined: Thu Apr 02, 2020 6:48 am

Re: Remote Desktop use of local Space Navigator

Post by dlouiselle » Thu Dec 17, 2020 7:01 am

I have been going back and forth with 3D on this subject.
Was told no drivers are to be loaded on the home computer.
Still haven't gotten anything to work.
I'm not a computer tech.

With all the people at home now, thousands.
That 3D wouldn't create a patch to allow remote access,
as easy as the keyboard or mouse which would prompt hundreds to buy their product for home use.
I know of CAD operators where I work who purchased 3D devices only to
find they won't work at home.

What an enormous loss of revenue.

pockybum522
Posts: 1
Joined: Mon Dec 21, 2020 9:47 am

Re: Remote Desktop use of local Space Navigator

Post by pockybum522 » Mon Dec 21, 2020 9:49 am

Here's what finally worked for me when I was in the same boat of it wouldn't show up in the RDP Local resources section no matter what I did.

It looks like a new windows update may have added a new item under RemoteFX USB Device Redirection. See below for modified instructions. Original instructions are not mine.

(Install the same version driver on the host and client PC. I used 64-bit fine.)

These settings need to be changed on both (host and client) systems.

RemoteFX does not work with the universal receiver. You need to connect your wireless device via cable.

Run gpedit.msc

In the group policy editor open

Computer Configuration ->
Administrative Templates ->
Windows Components ->
Remote Desktop Services ->
Remote Desktop Connection Client ->
RemoteFX USB Device Redirection.

Enable: "Allow RDP redirection of other supported RemoteFX USB devices "
THIS IS THE KICKER ====> And set USB redirection rights to "Administrators and Users"

Remote Desktop Services ->
Remote Desktop Session Host ->
Connections

Enable: "Allow user to connect remotely by using Remote Desktop Services ".

Remote Desktop Services ->
Remote Desktop Session Host ->
Device and Resource Redirection

Disable: "Do not allow supported Plug and Play device redirection".

Remote Desktop Services ->
Remote Desktop Session Host ->
Remote Session Environment ->
RemoteFX for Windows Server 2008

Enable: "Configure RemoteFX".

Now open the command prompt with administrative rights.
run "gpupdate /force"

Next restart the machine.

After the restart right click the RDP connection and press edit.

Go to the “Local Resources” tab
Click on “More” on the bottom of the window (section "Local devices and resources").

You should see "Other supported RemoteFX USB devices".
Open it - it shows the connected SpaceMouse device.
Activate the checkbox for the SpaceMouse device.
The device will be forwarded to your target system next time when you connect via RDP.

PeteFischer
Posts: 1
Joined: Sun Jan 03, 2021 12:03 pm

Re: Remote Desktop use of local Space Navigator

Post by PeteFischer » Sun Jan 03, 2021 12:49 pm

In addition to pockybum522 :
:

After the restart right click the RDP connection and press edit.

Go to the “Local Resources” tab
Click on “More” on the bottom of the window (section "Local devices and resources").


I experienced the following complication:

I already had several Remote desktop files name-1.rpd , name-2.rpd, name-3.rpd etc saved om my desktop.
It didn't work starting a session with clicking this saved configuration (s).
The supported RemoteFX USB devices didn't appear.

Instead, I had to make a new connection from scrap.

Type under left next to START "remote" The app appears. Right click the app and choose "start as a administrator' Now, fill in the address or host name and go to the “Local Resources” tab
Click on “More” on the bottom of the window (section "Local devices and resources"
Now the supported RemoteFX USB devices did appear.
Saving this as new connection. RDP om my desktop. didn’t work.
Ending and restarting the session gave me the same problem again.

So this is what i did:
Type next to START "remote". The app appears. Right click the app and choose "open file Location"
A link in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Accessories appears.
Right click the link and choose again "open file Location"
C:\Windows\system32\mstsc.exe
Right click mstsc.exe and choose : copy to ... Desktop ( make link)
Now you can right click this newly made link on your desktop and run it as an administrator.

JoschaW
Posts: 1
Joined: Fri Jan 22, 2021 3:13 am

Re: Remote Desktop use of local Space Navigator

Post by JoschaW » Fri Jan 22, 2021 3:26 am

pockybum522 wrote:
Mon Dec 21, 2020 9:49 am
Here's what finally worked for me when I was in the same boat of it wouldn't show up in the RDP Local resources section no matter what I did.

It looks like a new windows update may have added a new item under RemoteFX USB Device Redirection. See below for modified instructions. Original instructions are not mine.

(Install the same version driver on the host and client PC. I used 64-bit fine.)

These settings need to be changed on both (host and client) systems.

RemoteFX does not work with the universal receiver. You need to connect your wireless device via cable.

Run gpedit.msc

In the group policy editor open

Computer Configuration ->
Administrative Templates ->
Windows Components ->
Remote Desktop Services ->
Remote Desktop Connection Client ->
RemoteFX USB Device Redirection.

Enable: "Allow RDP redirection of other supported RemoteFX USB devices "
THIS IS THE KICKER ====> And set USB redirection rights to "Administrators and Users"

Remote Desktop Services ->
Remote Desktop Session Host ->
Connections

Enable: "Allow user to connect remotely by using Remote Desktop Services ".

Remote Desktop Services ->
Remote Desktop Session Host ->
Device and Resource Redirection

Disable: "Do not allow supported Plug and Play device redirection".

Remote Desktop Services ->
Remote Desktop Session Host ->
Remote Session Environment ->
RemoteFX for Windows Server 2008

Enable: "Configure RemoteFX".

Now open the command prompt with administrative rights.
run "gpupdate /force"

Next restart the machine.

After the restart right click the RDP connection and press edit.

Go to the “Local Resources” tab
Click on “More” on the bottom of the window (section "Local devices and resources").

You should see "Other supported RemoteFX USB devices".
Open it - it shows the connected SpaceMouse device.
Activate the checkbox for the SpaceMouse device.
The device will be forwarded to your target system next time when you connect via RDP.
Hi pockybum522 and the 3Dconnexion Community,

I'm new to this forum because I have a problem like everybody here :lol:
First things first:
Windows 10
computers connected via VPN
Inv2019
3Dconnexion driver 10.7 (on both machines)
I got the SpacePilot Pro (connected with cable) and it also shows up in the RDP. I checked the box, but it won't forward the signal to the work computer. (only like a zooming in/out).

So I checked every gpedit setting (home- and work-computer) and found one little mistake i made on the work computer. As you mentioned "set USB redirection rights to "Administrators and Users"".
I thought: THIS IS IT and now it has to work, but unfortunately it doesn't.

Am I missing there something? I tried to read every post in this forum, but maybe i oversaw something. If it is so, please point me out in the right direction.
I'm desperate.

Thanks a lot

Regards,
J

ravensachel
Posts: 1
Joined: Fri Jan 29, 2021 2:23 pm

Re: Remote Desktop use of local Space Navigator

Post by ravensachel » Fri Jan 29, 2021 2:35 pm

RemoteFX vGPU will be removed from all applicable Windows platforms in the February 2021 Windows security updates (February 9, 2021)



https://support.microsoft.com/en-us/hel ... -component

so on to the next potential Software solution i suppose....

NOBAG
Posts: 1
Joined: Thu Feb 18, 2021 11:53 am

Re: Remote Desktop use of local Space Navigator

Post by NOBAG » Thu Feb 18, 2021 12:13 pm

Hallo Zusammen,
habe hier eine bebilderte Anleitung geschrieben:
https://sites.google.com/view/remotefx/startseite
Funktioniert ohne Zusatzsoftware etc...
Viel Erfolg

EricV
Posts: 1
Joined: Mon Mar 15, 2021 6:54 am

Re: Remote Desktop use of local Space Navigator

Post by EricV » Mon Mar 15, 2021 6:59 am

Hello

i tried multiple suggestions but i'm a little stuck

product i have is : spacemouse enterprise
driver version: 10.7.1
problem: ctrl/alt/enter/etc. not working with remote desktop

the button bar 1 to 12 and turning etc works fine with remote

with adjusting de base.xml i cannot get it to work
what am i missing or did i do wrong ?
ideally i want to use it aat work computer and on remote computer the same

thnx in advance

antonynealrobinson
Posts: 31
Joined: Tue Mar 29, 2011 12:47 am

Re: Remote Desktop use of local Space Navigator

Post by antonynealrobinson » Mon Mar 15, 2021 9:54 am

Hello,

I use this global.xml file that I tidied up with notepad++ and allows the other keys to work.

Located in:
C:\Users\username\AppData\Roaming\3Dconnexion\3DxWare\Cfg

First create a fresh global.xml file and then looking at whats differnt between the two.
Also I'm not sure what will happen if you use the same spacemouse at home or in the office as you may need two differnt global.xml files.

Button actions area probably be the same for whichever CAD software is used.

Button bank area will change depending on what the CAd package alls each mode.

Bit cut/copy/paste maye solve the issue.

Good luck.
Attachments
Global.zip
(793 Bytes) Downloaded 15 times

Post Reply