Drifting from zero - space navigator

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
peter chaffe
Posts: 3
Joined: Wed Aug 12, 2009 3:44 am

Drifting from zero - space navigator

Post by peter chaffe » Wed Aug 12, 2009 4:08 am

Hi Gents,

I have a Space Navigator, it's started drifting from zero point when untouched, which is most annoying (about 6 months use)

Is there a solution?
Have downloaded latest drivers but no change!

Thanks!

Fred
Moderator
Moderator
Posts: 997
Joined: Wed Dec 06, 2006 7:15 am
Location: Rochester, NY
Contact:

Post by Fred » Wed Aug 12, 2009 4:22 am

Open the 3Dcontrol panel
click on Calibrate

peter chaffe
Posts: 3
Joined: Wed Aug 12, 2009 3:44 am

Post by peter chaffe » Wed Aug 12, 2009 5:39 am

Thanks for the quick reply Fred!

All ok now!

Peter

JesperJuul
Posts: 1
Joined: Thu May 05, 2016 1:13 pm

Re: Drifting from zero - space navigator

Post by JesperJuul » Thu May 05, 2016 1:16 pm

Hi My SpaceNavigator is also drifting and it does´t help to calibrate?

BR Jesper

UtaSH
Moderator
Moderator
Posts: 3669
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Drifting from zero - space navigator

Post by UtaSH » Fri May 06, 2016 8:24 am

Hi JesperJuul,

please contact our First Level Support Team. The colleagues can check if your device is eligible for a firmware update and if this would solve the issue. If not they will verify if the device is still under warranty (2 years) and if yes, we will replace the device if it is faulty.

ken0y
Posts: 13
Joined: Sun Aug 12, 2012 5:14 am

Re: Drifting from zero - space navigator

Post by ken0y » Mon May 23, 2016 1:13 am

Same problem, I recently received a brand new Spacepilot Pro in an attempt to solve this issue but the new device does the same thing.

Firmware is 4.11, is there an upgrade?

Cheers

UtaSH
Moderator
Moderator
Posts: 3669
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Drifting from zero - space navigator

Post by UtaSH » Tue May 24, 2016 4:35 am

Hello Ken0y,

the SpacePilot Pro is not eligible for a firmware update. You need to contact our Technical Support Team.

jeffrayner
Posts: 1
Joined: Mon Jan 23, 2017 5:33 pm

Re: Drifting from zero - space navigator

Post by jeffrayner » Tue Jan 24, 2017 10:56 am

I am experiencing the exact same thing.... constant drifting to the top left.
This appears to be mainly prevalent in any unity based solution.
I've tried adding the unity driver, yet does not fix it.
It's like the UP and RIGHT arrows are permanently depressed.
Uninstalling the driver solves the problem - yet renders the device useless ;(

Has anyone figured out a solution, or do I need to send this back?

PS have a brand new space navigator for notebooks

UtaSH
Moderator
Moderator
Posts: 3669
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Drifting from zero - space navigator

Post by UtaSH » Wed Jan 25, 2017 4:14 am

Hi jeffrayner,

please contact our Support Team. They will do the necessary troubleshooting and start the RMA process for you is necessary.

rotorAi
Posts: 1
Joined: Tue Jan 31, 2017 7:06 pm

Re: Drifting from zero - space navigator

Post by rotorAi » Tue Jan 31, 2017 7:11 pm

I am experiencing the same issue with SpacePilot Pro. This started immediately when I upgraded to ver. 10, worked fine previously. Calibration does nothing. It is about to go in the trash! Would be nice if you could create a deadband in the app.

UtaSH
Moderator
Moderator
Posts: 3669
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Drifting from zero - space navigator

Post by UtaSH » Wed Feb 01, 2017 3:07 am

Hi rotorAi,

you can add a deadband by adding the following to your Global.xml (in %AppData%\3Dconnexion\3DxWare\Cfg):

Code: Select all

<Settings>
…
   <Deadband>150</Deadband>
</Settings>
It is used for all devices. The range is the input range of the device, ~350.

Zomborro
Posts: 1
Joined: Sat Apr 15, 2017 3:51 am

Re: Drifting from zero - space navigator

Post by Zomborro » Sat Apr 15, 2017 3:52 am

Where can I find these deadband settings on MacOS?

UtaSH
Moderator
Moderator
Posts: 3669
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Drifting from zero - space navigator

Post by UtaSH » Wed Apr 19, 2017 2:07 am

Not available on Mac. Sorry.

ahoym8z
Posts: 3
Joined: Sat Feb 10, 2018 11:17 am

Re: Drifting from zero - space navigator

Post by ahoym8z » Sat Feb 10, 2018 11:30 am

I have solved this issue (and over-drift) several times as follows. I think it is related to having more than one Spaceball model touch your machine, or different versions of the software having been installed.
  • Uninstall the 3D Connection software
  • Reinstall and select the Custom option (not Standard)
  • Watch for a menu with three check-boxes. Turn on the last one that says something like "Remove all saved settings"

yoshivan
Posts: 1
Joined: Mon Nov 19, 2018 5:25 pm

Re: Drifting from zero - space navigator

Post by yoshivan » Mon Nov 19, 2018 6:46 pm

ahoym8z wrote:
Sat Feb 10, 2018 11:30 am
I have solved this issue (and over-drift) several times as follows. I think it is related to having more than one Spaceball model touch your machine, or different versions of the software having been installed.
  • Uninstall the 3D Connection software
  • Reinstall and select the Custom option (not Standard)
  • Watch for a menu with three check-boxes. Turn on the last one that says something like "Remove all saved settings"
I tried this but no luck! Has anyone got a solution yet?
Sketchup pro 2018 on Windows 10 on Surface Book2 with Spacemouse Pro


I tried on my desktop which is SU pro 2016 on Windows 10 then no drifting issue at all...

Post Reply