3DxWare64 v10.5.4 r2703 Not Working in Windows 10 64 bit

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Posts: 2
Joined: Sun Feb 18, 2018 4:45 pm

3DxWare64 v10.5.4 r2703 Not Working in Windows 10 64 bit

Post by archiebald » Sun Feb 18, 2018 6:13 pm

Just a heads up. I have been using my Space Mouse Wireless quite okay for the last 2 months with the latest drivers, however, suddenly the mouse stopped working. Here is what I found;

First I tried by uninstalling and re-installing the v10.5.4 r2703drivers that had been working okay. The driver installed okay, the system recognized the universal receiver and I was able to use the pairing utility to confirm communication with the mouse. I even tried re-downloading the drivers in case I had a corrupted file. However in all cases, no application could recognize the mouse, even the 3D Connexion Trainer, Viewer and Demo etc. Also the 3Dx Properties dialog could not be opened in Windows Control Panel.

I was quite frankly pulling my hair out. Then I I uninstalled v10.5.4 and installed an archived driver v10.4.10 r2558 from earlier in 2017 and everything seems to be working fine now.

Just for information, I confirmed this problem on two separate PC's running Windows 10, one is 1709 Build 16299.248 and 1709 Build 16299.192 with exactly the same result. I read that some people have had issues with AVG antivirus but I am not using it. One PC is running ESET antivirus and the other is just running vanilla Windows Defender.

Since it was working for me prior to several days ago, I can only assume something in a Windows Update has caused the issue with the 3DxWare.

Posts: 3738
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany

Re: 3DxWare64 v10.5.4 r2703 Not Working in Windows 10 64 bit

Post by UtaSH » Thu Mar 08, 2018 2:23 am

Hi archiebald,

I assume that you ran into a problem that we had with 3DxWare 10.5.4. If you haven't used the device/driver for 7 days or more the driver didn't recognize it anymore. We had an FAQ available with a workaround until we released 3DxWare 10.5.5 which does not have this problem. :)

So my recommendation would be to install our latest driver. :)

Post Reply