New Driver causing all sorts of issues

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

hughwyeth
Posts: 30
Joined: Sat Jul 03, 2010 8:18 am

New Driver causing all sorts of issues

Post by hughwyeth » Wed Jan 08, 2020 2:21 am

Hey guys,

Just updated to the newest driver (10.6.4) and having a load of issues with max.

The zoom has now changed so it animates a move to the zoom location instead of jumping there. It's minor, but annoying as it feels so much slower than before! Is there a way to go back to jumping to the zoom location?

The most annoying issues is there's something wrong with how the drivers now navigate in the viewport. It seems to be randomly changing the intensity of rotation and movement so that a slight tap on the spacemouse will cause the view to move 100s of meters, but to rotate 10 degrees requires a twist to the full extent and 10 seconds of time to do. Then it'll randomly go back to being ok. In addition, the view will jump forward and backwards randomly, though when rendered will be the correct view.

I'm downloading 10.6.3 in the meantime but wanted to see if anyone was having similar issues? Running max 2019 on windows 10 with all latest drivers.

Alpenshiva
Posts: 7
Joined: Wed Jun 04, 2014 12:10 am

Re: New Driver causing all sorts of issues

Post by Alpenshiva » Wed Jan 08, 2020 6:15 am

I have the same problems with 3ds max.
Space Pilot Pro also moves locked camera views which is annoying.
I use 3DxWare64_v10-6-0_r2972 again until the problems are fixed.

tneveu1
Posts: 5
Joined: Tue Jan 07, 2020 5:58 pm

Re: New Driver causing all sorts of issues

Post by tneveu1 » Wed Jan 08, 2020 7:37 am

I also had a lot of issues with the new driver with Maya. In fact, it was making models NOT display when I loaded a previous file. It was very weird. I also went back to 10.6.0 and it seems fine again.

hughwyeth
Posts: 30
Joined: Sat Jul 03, 2010 8:18 am

Re: New Driver causing all sorts of issues

Post by hughwyeth » Wed Jan 08, 2020 7:56 am

Yeah also moves locked cameras for me. Rolled back seems to work ok.

Vivifyer
Posts: 4
Joined: Thu Jan 09, 2020 1:14 am

Re: New Driver causing all sorts of issues

Post by Vivifyer » Thu Jan 09, 2020 1:25 am

new driver is a total mess.

installed it today, and very quickly realised something was very wrong.

in 3dsmax using viewport clipping to stop flickering on big scenes 100% inhibits your ability to pan with the spacemouse. the moment you turn clipping off it goes back to working.

along with the same problems everyone else seems to be suffering from. downloading 10.6.0 to get it working again.

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Thu Jan 09, 2020 3:30 am

tneveu1 wrote:
Wed Jan 08, 2020 7:37 am
I also had a lot of issues with the new driver with Maya. In fact, it was making models NOT display when I loaded a previous file. It was very weird. I also went back to 10.6.0 and it seems fine again.
Could you please specify the issues you had and if possible supply a simply model file that illustrates the NOT displaying issue.

Thanks

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Thu Jan 09, 2020 5:33 am

Vivifyer wrote:
Thu Jan 09, 2020 1:25 am
in 3dsmax using viewport clipping to stop flickering on big scenes 100% inhibits your ability to pan with the spacemouse. the moment you turn clipping off it goes back to working.
It looks like the issues with panning are related to the near clipping plane distance.

hughwyeth
Posts: 30
Joined: Sat Jul 03, 2010 8:18 am

Re: New Driver causing all sorts of issues

Post by hughwyeth » Thu Jan 09, 2020 7:28 am

Another issue- the preference for camera mode- object/target camera/camera seems to reset with every instance of Max that is run, defaulting back to object mode - a mode which i will never use!

Just wanted to check that these issues are known and that there is a fix coming or is it not a widely-reported issue with these new drivers?

Vivifyer
Posts: 4
Joined: Thu Jan 09, 2020 1:14 am

Re: New Driver causing all sorts of issues

Post by Vivifyer » Thu Jan 09, 2020 5:43 pm

mbonk wrote:
Thu Jan 09, 2020 5:33 am
It looks like the issues with panning are related to the near clipping plane distance.
correct. but this is something I and a lot of others use on all their scenes, because of 3dsmax zfighting flicker. which near clipping seems to take care of. After installing 10.6.0 again all issues with panning are fixed.

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Fri Jan 10, 2020 12:16 am

hughwyeth wrote:
Wed Jan 08, 2020 2:21 am
Hey guys,
[…]In addition, the view will jump forward and backwards randomly, though when rendered will be the correct view.[…]
I am uncertain if I am seeing this issue. I have a viewport looking through a light, which will randomly switch to perspective and back again (the same seems to apply when looking through a camera) when navigating with the 3D Mouse. The navigation tools in the bottom right corner follow suite as well.

Is this what you mean?

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Fri Jan 10, 2020 12:20 am

Vivifyer wrote:
Thu Jan 09, 2020 5:43 pm
mbonk wrote:
Thu Jan 09, 2020 5:33 am
It looks like the issues with panning are related to the near clipping plane distance.
correct.[…]
This will be fixed next release.

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Fri Jan 10, 2020 12:32 am

hughwyeth wrote:
Thu Jan 09, 2020 7:28 am
Another issue- the preference for camera mode- object/target camera/camera seems to reset with every instance of Max that is run, defaulting back to object mode - a mode which i will never use!
I cannot reproduce this: The default navigation mode for 3ds Max is 'Target Camera Mode'.
Would you zip up the contents of %localappdata%\3Dconnexion\3DxWare and send it to me.

hughwyeth
Posts: 30
Joined: Sat Jul 03, 2010 8:18 am

Re: New Driver causing all sorts of issues

Post by hughwyeth » Fri Jan 10, 2020 2:16 am

Hi-uploaded the contents here- https://we.tl/t-pJPM4zEvpM

hughwyeth
Posts: 30
Joined: Sat Jul 03, 2010 8:18 am

Re: New Driver causing all sorts of issues

Post by hughwyeth » Fri Jan 10, 2020 2:17 am

mbonk wrote:
Fri Jan 10, 2020 12:16 am
hughwyeth wrote:
Wed Jan 08, 2020 2:21 am
Hey guys,
[…]In addition, the view will jump forward and backwards randomly, though when rendered will be the correct view.[…]
I am uncertain if I am seeing this issue. I have a viewport looking through a light, which will randomly switch to perspective and back again (the same seems to apply when looking through a camera) when navigating with the 3D Mouse. The navigation tools in the bottom right corner follow suite as well.

Is this what you mean?
It's similar to this- but seems to be the same view as the camera and switches between zoomed in and out?

mbonk
Moderator
Moderator
Posts: 178
Joined: Mon Dec 04, 2006 4:06 am

Re: New Driver causing all sorts of issues

Post by mbonk » Fri Jan 10, 2020 2:43 am

hughwyeth wrote:
Fri Jan 10, 2020 2:17 am
It's similar to this- but seems to be the same view as the camera and switches between zoomed in and out?
Sounds like it - at the end of navigation when you let go of the cap?

Post Reply