Space Navigator on SketchUp 2020 Zooming problem

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Posts: 6
Joined: Fri Oct 30, 2020 7:37 am

Re: Space Navigator on SketchUp 2020 Zooming problem

Post by Matheron » Fri Oct 30, 2020 2:24 pm

Hello –

First post here. Since 2014, I am an avid user of 3DConnexion spacemice, thank you!

I regularly teach Sketchup to companies and higher education, meeting hundreds of users every year. I have always encouraged my students to acquire a 3DConnection spacemouse. I have tree spacemice and love them all. I typically use the classical standard 3DConnexion spacemouse with the latest version of Sketchup Pro.

A very frequent user behaviour is to navigate the model using both the spacemouse and the standard mouse at the same time. This helps momentarily boost the navigation. It is much faster and gives much more control than only using one device at a time. In contrast to many other 3D modelling applications, Sketchup has only one viewport. Therefore, fast and controlled mouse navigation is especially important in Sketchup. Veteran Sketchup users navigate frequently and aggressively. The best way to navigate in Sketchup is to use both a standard mouse and a spacemouse concurrently. This makes as much sense as using both hands to steer a bicycle.

However, something has happened. The issue started around the beginning of 2019.

The issue consists in 3DConnexion's 3DXWare driver conflicting with native Sketchup navigation. The issue is seen most clearly when using the spacemouse to zoom while simultaneously using the standard three-button mousewheel to zoom. When you zoom in on both devices, or zoom out on both devices, the whole viewport shudders, quakes, and jerks about violently, as if it were having an epileptic seizure. The Sketchup viewport behaves as if the two devices were constantly fighting for priority instead of cooperating. It looks as if one device were pulling inwards and another were pulling outwards, even though inputs in fact are towards the same direction.

This behaviour, besides not being what users expect, is very distracting and unpleasant, and renders simultaneous device navigation, especially zooming, effectively unusable.

Users' justified expectation would instead be that the 3DConnexion driver behaved as it did up to late 2018: when inputs from the two devices point in the same direction, the viewport result pulls in the same direction, and faster than if only one input were active. The result should at all times just sum the two input vectors.

And yes, this is the exact same issue as jwhida, the original poster, describes above. The issue is clearly illustrated in Jwhidas video here: ...

I use Sketchup 2020, but this same issue occurs also with all earlier Sketchup versions I have checked, e.g.:
Sketchup Pro 2020
Sketchup Pro 2019
Sketchup Pro 2018

This issue affects at least these driver versions:

The only workaround I know is using older drivers. The newest driver that I have confirmed to not suffer from the issue described above is from 2018:

However, Sketchup is moving on. Typically, Trimble releases a new Sketchup year version around the end of each year. Sooner or later, there may be breaking changes in Sketchup that make older 3DXWare drivers completely useless. If this happens, the 2018 driver workaround will no longer work.

• Are 3DXWare developers aware of this issue?

• What is the status of this issue?

• Would you please fix this issue in your next release?

Posts: 60
Joined: Mon Apr 15, 2019 9:14 am

Re: Space Navigator on SketchUp 2020 Zooming problem

Post by aalsalihi » Thu Nov 05, 2020 6:57 am

Hello Matheron,

Thanks for sharing this, I've tried reproducing the issue on my end and i couldn't get the same outcome per your provided video.
Do you have different plugins or add-ons within Sketchup? Sometimes this might cause an issue similar to what you encountering right now!
If you do have add-ons/plugins then please try to disable some and see if the issue still persist.
If you still encountering the issue then we might need to generate a diagnostic folder to see why this happening on your end which you might need to create a technical case and submit it to us here

Will be waiting for some updates on your end.

Abdul. A

Posts: 6
Joined: Fri Oct 30, 2020 7:37 am

Re: Space Navigator on SketchUp 2020 Zooming problem

Post by Matheron » Thu Nov 19, 2020 12:21 am

Hello Abdul -

Thank you. This issue is real.

I can reproduce it in all combinations of installed Sketchup extensions that I have tried. This issue affects all tested versions of 3DX Ware since sometime late 2018, i.e. more than two years back. This issue persists across all versions of Sketchup I have tested.

I have submitted a support case to 3DConnexion. Christophe at 3DConnexion's support staff has clearly recognized this issue. 3DConnexion has labelled this issue internally as WIN-632.

Please note that:

1) The WIN-632 issue does not only concern zoom. It concerns panning, and orbiting,and zooming . In fact, all tandem navigation is clearly and adversely affected.

2) The WIN-632 issue is an obvious regression. For many years, mouse and spacemouse navigation have been working together excellently. Then, suddenly, something broke in the 3DXWare Drivers. Concurrent navigation in effect stopped working.

3) During the many years that mouse and spacemouse input have been working excellently together, perceived performance was higher. The reason is that users could navigate their modelspace much faster and more controlled than we can today.

I would just like to warn all other users. In Sketchup, you will no longer be able to use your mouse and your spacemouse concurrently.

We very much look forward to a solution.

Posts: 6
Joined: Fri Oct 30, 2020 7:37 am

Spacemouse + SketchUp Zooming Issue

Post by Matheron » Mon Dec 07, 2020 7:33 am

No new driver. No solution. No reply.

• What is the current status of this issue?

Posts: 3655
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany

Re: Space Navigator on SketchUp 2020 Zooming problem

Post by UtaSH » Mon Dec 14, 2020 8:54 am

Try this.

Post Reply