SpaceMouse Compact not working

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
Posts: 1
Joined: Fri May 01, 2020 6:32 am

SpaceMouse Compact not working

Post by Sp101297 » Fri May 01, 2020 6:36 am


I just recieved my space mouse compact. I downloaded the drivers from the website but when plugged into my pc the lights don't come on and the device doesn't work.

I'm able to find the device in device manager but it gives the message "windows usb device descriptor request failed".

I've tried the device on another computer (a mac) and it worked as expected.

Not sure what to try so any advice would be appreciated.



Posts: 60
Joined: Mon Apr 15, 2019 9:14 am

Re: SpaceMouse Compact not working

Post by aalsalihi » Fri May 01, 2020 8:04 am

Hi Sp101297,

I would assume this error message was encountered or listed in Device Manager indicating the device is not being recognized by your machine.
There's multiple fixes for this issue and you could check these links I've attached for your below:

Source 1: ... -p/5973953
Source 2: ... failed.php

Abdul. A

Posts: 394
Joined: Wed Mar 20, 2019 5:54 pm

Re: SpaceMouse Compact not working

Post by luping » Fri May 01, 2020 4:50 pm

What's your 3DxWare driver version? Plug the 3D mouse at first, then install the driver with administrator privilege.

Post Reply