SpaceMouse configuration AutoCAD / AutoCAD OEM 3Party application

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
JormaS73
Posts: 4
Joined: Thu Oct 31, 2013 8:43 am

SpaceMouse configuration AutoCAD / AutoCAD OEM 3Party application

Post by JormaS73 » Mon Jul 06, 2020 9:48 am

Hi, everybody,

On one workstation we have both AutoCAD (used for generic and mechanical drawing) and Vest HyDrawCAD (a vertical application based on AutoCAD OEM specific for the realization of hydraulic diagrams).

With both we would like to use our SpaceMouse Enterprise.

The problem we are observing concerns 3DxWare configuration files.

If we start AutoCAD and configure the 3DxWare settings, the configuration file is saved as AutoCAD.XML and everything works correctly but if we then start HyDraw, which to all intents and purposes is a different executable (HyDraw.exe vs. ACAD.exe) it seems that 3DxWare still "recognizes" it as if it were AutoCAD.

The result is that the configuration file is overwritten but worse is reset each time as if it had never been configured.

We noticed that inside the configuration file the following happens when we start HyDraw:

<Signatures>
<Name>AutoCAD</Name>
<ExecutableName>HyDraw.exe</ExecutableName>
<SiOpenAppName>AutoCAD</SiOpenAppName>
</Signatures>

When we start AutoCAD the file is overwritten again and <ExecutableName> is set to ACAD.exe.

We would like to know if this situation also occurs to other users working with other vertical products based on AutoCAD OEM and if it is possible, in some way, to circumvent the problem.

Even if the settings were not independent (i.e. when set for AutoCAD they were also valid for HyDraw) it would be fine; the main problem is that they are reset at every step between applications.

Note: we tested also using AutoCAD LT instead of AutoCAD; in this case everything works regularly.

Thank you in advance for any suggestions.

Post Reply