Silent Installs

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
cranston
Posts: 1
Joined: Tue Jul 24, 2007 2:05 pm

Silent Installs

Post by cranston » Tue Sep 22, 2020 12:00 pm

Hi,

In the past I would record a response file and deploy drivers using that. The newer (about 10.6.7+) installer is supposed to work similarly but it doesn't seem to be able to record anything using the switch SaveSettings=”c:\temp\3DxWareSettings.xml". I get an error at the end of the install telling me it could not write the XML file. It does install fine though, just not record the responses.

Has anyone been successful with the above method? Or do you just silent install each desired MSI?

Thanks,
-Brian

ngomes
Moderator
Moderator
Posts: 2044
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: Silent Installs

Post by ngomes » Wed Sep 23, 2020 1:13 am

Hi cranston,
cranston wrote:
Tue Sep 22, 2020 12:00 pm
The newer (about 10.6.7+) installer is supposed to work similarly but it doesn't seem to be able to record anything using the switch SaveSettings=”c:\temp\3DxWareSettings.xml". I get an error at the end of the install telling me it could not write the XML file. It does install fine though, just not record the responses.
Can you please recheck the exact command-line that you're using? I suspect you may have invalid characters in the path of the XML file (you have a curly ” double quote in your example) or the directory does not exist.

When running the installer to capture the installation settings, the command-line can be:

Code: Select all

<executable file name> SaveSettings="c:\temp\3DxWareSettings.xml"
The "c:\temp\" directory must already exist before running the software.

To use the XML file in subsequent installations, use the "LoadSettings" command line option.

For a summary of the available commands and options, run the installer with the "/help" command.
Nuno Gomes

Post Reply