deadband makes Rhino crash

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
sumguy
Posts: 13
Joined: Tue Jul 15, 2014 7:28 am

deadband makes Rhino crash

Post by sumguy » Tue Jul 15, 2014 9:14 am

Hi, I just purchased a SpaceNavigator for Notebooks, using it with Rhino 5. I've never used a 3D mouse before...

Got it installed, but the control knob seems way too sensitive, it activates if I so much as breathe on it... makes it difficult to use. I'm not talking about the Speed, I want to adjust the Threshold, which I guess is no longer in the GUI for some reason?

So finally I found this forum post:
viewtopic.php?f=25&t=8181&p=34358#p34358
saying to add eg. <Deadband>10</Deadband> parameter to the Settings in the %appdata%\3dconnexion\3DxWare\Cfg\Global_User.xml file. After doing "LEDs Active" from the tray icon a couple of times in order to get that file created, I added the deaband. Now in the demo apps, it's working well. But Rhino won't start up properly anymore. If I remove the <Deadband> parameter from the xml file, Rhino works normally again.

Is there another way to do this? Is it a bug in Rhino that I'll have to wait for them to fix? I tried changing the Rhino.xml file from:
<Settings/>
to:
<Settings><Deadband>10</Deadband></Settings>
...but it didn't seem to do anything. Is there some good documentation about the xml files somewhere?

The symptoms are:
- Rhino starts and draws the screen, and the splash screen fades out
- Rhino window then goes to the background, behind other windows. Can't bring it to the foreground by clicking on it.
- Task Manager shows 3DxService.exe using 50-100% cpu, Rhino.exe using 0-1%. My laptop's fans come on...
- ending the Rhino process brings 3DxService.exe back to 0-1% cpu
- alternatively, ending the 3DxService.exe process instead, lets the Rhino window come to the foreground, but I get the hourglass and "Not Responding"

jwick
Moderator
Moderator
Posts: 2711
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: deadband makes Rhino crash

Post by jwick » Tue Jul 15, 2014 9:45 am

I think Deadband was broken in that release (fixed for the next).
You can put it in the individual axes.
But if Rhino is way too sensitive, I'd first make sure your device is recognized in the Device Manager.
Make sure it works correctly in the demos (puzzle, jet, cube3d).

sumguy
Posts: 13
Joined: Tue Jul 15, 2014 7:28 am

Re: deadband makes Rhino crash

Post by sumguy » Tue Jul 15, 2014 11:11 am

Thanks for your answer...

I'm using very latest Rhino 5.9.40617.14345 (2014-6-17), you mean Deadband is broken in that, and I should expect it to be fixed in the next release? or it's broken in 3DxWare?

Not sure what you mean by "put it in the individual axes" - is there some documentation about the xml file syntax somewhere?

So I'll have to edit the xml file for every application, to set a global deadband? It's too sensitive in the demos too, not just Rhino. I literally can't touch the knob without starting to move the model, and if I bump the desk, the viewport shakes... Is that normal? Setting a deadband around 10 seems to take care of it for me, it works quite well in the demos after that.

jwick
Moderator
Moderator
Posts: 2711
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: deadband makes Rhino crash

Post by jwick » Wed Jul 16, 2014 1:25 am

The Global Deadband is broken in the current release of 3DxWare. It is fixed for the next release, but that won't be for a while.
It doesn't seem right that you should be complaining that it is too sensitive. Give tech support a call and talk to them about it. Maybe it is a hardware issue.

You can probably set the individual axes in Base.xml and all other Cfgs would pick it up.
1) Find your device in base.xml
2) For each axis (6 of them), change the Input/Deadband from 0 to whatever value works for you
3) Save the file and bounce the driver

sumguy
Posts: 13
Joined: Tue Jul 15, 2014 7:28 am

Re: deadband makes Rhino crash

Post by sumguy » Thu Jul 17, 2014 7:25 am

The Deadband in Global_User.xml seems to work for all the demo apps, as well as Sketchup. It's only a problem with Rhino.

Maybe I just haven't figured out the proper technique yet. Is it normal that you should completely remove your hand from the cap when you're not moving the model? With 0 deadband, I find I have to hold my fingers in mid-air, or move my whole hand away. Also it's nearly impossible for me to move only one axis without "dominant" set. With a small threshold, I can rest my fingers lightly on the cap, and get better control without having to set "dominant". I did notice a couple of other forum posts where people remarked that their SpaceNavigator seemed too sensitive.

Anyway, I managed to find the Base.xml file and change the Deadband entries for the "Standard 3D Mouse". Also changed the Y/Z axes because I prefer the Up/Down Zoom Direction. So now everything seems to be working fine, and all the apps pick it up, thanks!

To be honest, I was about ready to pack it up and send it back, until I tried it on a Mac and realized it was possible to set thresholds, as well as global mappings for "any application". I guess you're still working on the Windows GUI, but it would have been nice if it had been a bit easier to find out how to do that. I don't mind editing xml files, but it took me a whole day of rooting around the support site and forum... maybe a pointer in the FAQ, and a basic help file about editing the xml files?

p.s., how can I "bounce the driver" after editing the Base.xml, other than restarting Windows?

jwick
Moderator
Moderator
Posts: 2711
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: deadband makes Rhino crash

Post by jwick » Thu Jul 17, 2014 7:51 am

That's a good point about being able to rest your hand a bit on the device. It detects very small displacements. It will definitely detect that. That is a good use of the DeadBand. We usually find people want it when the have a moving work environment (in a trailer, wobbly desk, etc.). The devices with a place to rest your fingers are probably better than minimal devices like the SpaceNavigators.

It isn't meant to be a precision single axis controller (move 5 cm along X, then 2 cm along Z, ...). It is a general view controller. The part/scene should be constantly moving around in your hand, exactly as if you had it in your hand.

There are Stop Driver and Start Driver shortcuts in the Start menu / start/apps screen if W8.

sumguy
Posts: 13
Joined: Tue Jul 15, 2014 7:28 am

Re: deadband makes Rhino crash

Post by sumguy » Thu Jul 17, 2014 12:47 pm

I'm starting to get better at it... at first I was using a very light touch because it seemed so sensitive, but now I'm finding a firmer grip works better. Anyway I'm glad I found out how to edit those files and tweak things a bit, thanks.

Post Reply