Windows dead zone/threshold settings?

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

Post Reply
zacaj
Posts: 5
Joined: Wed Nov 20, 2019 7:28 am

Windows dead zone/threshold settings?

Post by zacaj » Wed Nov 20, 2019 7:39 am

I'm using a SpaceMouse compact with windows, and I can't find any settings to control the deadzone. If I plug it into my mac, the settings have an option for 'threshold' to control this. Is this not available on windows?

jwick
Moderator
Moderator
Posts: 2921
Joined: Wed Dec 20, 2006 2:25 pm
Location: USA
Contact:

Re: Windows dead zone/threshold settings?

Post by jwick » Wed Nov 20, 2019 8:30 am

It can be set at the global level, the application level or the axis level:
Global.xml: GlobalCfg/Settings/Deadband
An AppCfg: AppCfg/Settings/Deadband
or AppCfg/Devices/Device/Axis/Input/Deadband

Windamyre
Posts: 1
Joined: Sun Mar 15, 2020 11:27 am

Re: Windows dead zone/threshold settings?

Post by Windamyre » Sun Mar 15, 2020 11:45 am

It can be set at the global level, the application level or the axis level:
Global.xml: GlobalCfg/Settings/Deadband
An AppCfg: AppCfg/Settings/Deadband
or AppCfg/Devices/Device/Axis/Input/Deadband
Thanks for this! I was also running into problems with everything short of a stray breeze sending my viewport spinning.

Why this isn't an option on the settings window is beyond me!

For those who don't know how to apply the setting (and I was one of them until I did more looking), here's the rest of the info:
--Find the file. For me it was in c:\users\Windamrye\AppData\Roaming\3Dconnexion\3DxWare\Cfg\Global.xml as I'm a Windows user and my username is Windamyre. Your user name will likely be different. Also, the AppData folder is hidden by default, but you can un-hide it using https://www.howtogeek.com/howto/windows ... ows-vista/.
--If the file doesn't exist, someone said you can force it to be created by turning the LEDs off and on again from the task bar.

--Make a copy of the file. Something like Global.bak or something just in case you screw up.

--Open the original file in any text editor. Notepad works. Look for the part at the end where it says "</Settings><Devices/>"

--Just before that part insert the text below. The number is the size of the deadband, so you'll want to adjust it to suit
<Deadband>100</Deadband>

--Save the file.

--I rebooted my PC. Not sure if that was necessary, but I wasn't sure how else to get 3DxWare to reload the setting.

That should do it. Again, I have no idea why the hell they didn't include something like this in the settings window. Baffles me.

Post Reply