Maya 2020

Questions and answers about 3Dconnexion devices on Windows.

Moderator: Moderators

ep19ma
Posts: 5
Joined: Sat Dec 26, 2020 7:11 am

Re: Maya 2020

Post by ep19ma » Fri Jan 01, 2021 6:53 am

still
Attachments
oce.png
oce.png (135.42 KiB) Viewed 1150 times

Janoshx
Posts: 39
Joined: Wed Jul 13, 2016 4:16 am

Re: Maya 2020

Post by Janoshx » Tue Jan 05, 2021 12:59 pm

I did some tests with Maya versions.

It seems that the latest driver version (3DxWare 10.7.1.3280 + 3DxWinCore 17.7.1.17950) breaks at least Maya extrusion tool. The tool is the one that you use with transform tool by selecting faces and dragging them with mouse while you hold Shift key in keyboard. If the plugin is loaded in Maya the broken behavior starts to happen. I tried this with Maya 2020.4 and with 2019.2. Tried with Maya default settings as well as with my normal settings that has all sorts of scripts available on shelves, none of them are loaded by default of course. Both Maya versions behave exactly the same when 3D connexion plugin is loaded.

Also worth noting that after i disable or remove the 3d connexion driver for Maya, the Maya does not suffer from sudden fatal crashes mentioned in previous posts. The fatal crashes happen several times in day or even in hour if the 3dconnexion plugin is loaded in Maya. I have not used Maya so much lately that i used to few months ago.

The fatal crashes happen usually when i am manipulating mesh with extrusions, bevels or maya multicut tool. They happen when you do something that changes vertex count, not when you are rotating, moving or scaling things.

I Made a screen recording about this behavior and you can see it from my dropbox link --> https://www.dropbox.com/sh/bp2elp23fxe7 ... 1zaYa?dl=0

In video i do some extrusions and then i disable the plugin via Maya plugin manager and you can see that the wrong behavior ends.

I tried same with my other secondary workstation that has still older 3d connexion driver version and there everything works fine. The working driver was 10.6.9.3230. I would try the latest driver with this workstation as well but it seems that the current working driver version is not anymore available at 3D Connexion drive archive so without installer for the current driver I AM NOT GOING TO TEST THE LATEST DRIVER on my secondary workstation.

It would be really good if all previous drive versions would be available in archives as they used to be. Please give me a link to 10.6.9.3230 driver so i can test the latest one on my secondary workstation and they older one in my primary workstation so i could cross check.

My primary workstation specs are following:
asus x399-e gaming with 2950x threadripper / 128G ram / Nvidia RTX Titan + Nvidia RTX 2080Ti. Both GPUs have single 4k monitor.

My secondary workstation:
Asus x370 prime pro with 1800x ryzen cpu / 128G ram / Nvidia 1080ti

I also tried the latest beta driver for macOS High sierra and it the 3d connexion plugin works as expected as does the maya extrude tool. I dont also have sudden crashes with Maya on mac.

Janoshx
Posts: 39
Joined: Wed Jul 13, 2016 4:16 am

Re: Maya 2020

Post by Janoshx » Tue Jan 05, 2021 2:02 pm

I did more testing after i found all drivers from website. It seems that if you filter "windows 64" it shows only 4 drivers....

Anyway.... Both Maya 2019.2 and Maya 2020.4 seems to work normally if you use https://download.3dconnexion.com/driver ... _r3248.exe version.

Janoshx
Posts: 39
Joined: Wed Jul 13, 2016 4:16 am

Re: Maya 2020

Post by Janoshx » Wed Jan 06, 2021 3:17 am

New day and new testing...

I kept thinking last night how it is possible that i could not find the driver from your website and i found a solution for that as well...

You are offering different set of drivers on different website locales. All driver versions are available if you go to UK version of your website. In UK website there is more drivers available than in DE website. Try it yourself. DE has 12 and UK has 16 drivers for Spacemouse Pro. Just change the DE to UK from the url and you find all driver versions....

https://3dconnexion.com/de/archived-dri ... emouse-pro
https://3dconnexion.com/uk/archived-dri ... emouse-pro

Since I found the "older driver" I tested this with my secondary workstation and the bug appears there as well so the bug is in the driver in some level so I made more test.

I keep my Spacemouse connected to hub that is connected to my monitors usb port. My monitor is directly connected to my primary and secondary workstations and has usb switch inside so i tried if that would be the culprit. I changed it to be connected directly to the computer --> no effect, bug still appears

Tried different driver versions and with Maya and I cannot replicate it with driver 3DxWare64_v10-7-0_r3248 so the bug is in the latest driver version

It really bugs me that in Maya plugin the default controls are in "camera mode". I always have to set it in "object mode" which is easier for my brains so I always set my settings to be "object mode" at least. This does not have affect to the bug but the root cause of the bug is on this settings page.
3DConnexion_BUG_ROOT_CAUSE.png
3DConnexion_BUG_ROOT_CAUSE.png (90.38 KiB) Viewed 1135 times
The bug appears only if Rotation center has "Use selected item" selected.
This feature is really good if you navigate in complex scene. Camera rotation point is always the origin of the object you have selected or the center of the face or vertex etc so i keep it always on. Unfortunately in the latest driver this setting triggers the bug

Unless you want to use Zbrush with 3D mouse you should use the 3DxWare64_v10-7-0_r3248 driver version. You can use 3D mouse with Maya without using Rotation center "Use selected item" mode, for me it seems to work fine except the camera rotate point of course. If this is really important there is a 3rd party script to do this.
https://lesterbanks.com/2016/01/auto-ce ... pting-app/

I don't know if this helps to Maya Fatal crashes. It did not happen to me on either my workstations when debugging this but i was not doing anything serious modeling anyways. This bug is still so severe that it practically prevents do do any serious modeling since it keeps selecting and moving wrong faces while modeling with extrusions which is one of the key modeling feature.

What makes this bug more severe is that the settings that cause this bug is set by default when you install this driver. I tried if it happens with no 3d mouse connected and it surely does. This means that if an artist(or engineer) gets brand new computer with driver 3DxWare64_v10-7-1_r3280 and Maya installed but no 3D mouse connected. Or if artist does not want to use 3D mouse, so it is not connected because personal preference(which is very common), it will be very difficult to find out why this bug is happening. This is because you cannot change these settings from the 3D connexion task bar tray icon menu properties without having 3D mouse connected.
3DConnexion_TRAY_ICON_PROPERTIES_WITHOUT_3DMOUSE.png
3DConnexion_TRAY_ICON_PROPERTIES_WITHOUT_3DMOUSE.png (100.17 KiB) Viewed 1135 times

That's all folks... Lets hope that year 2021 is better than 2020....

mbonk
Moderator
Moderator
Posts: 179
Joined: Mon Dec 04, 2006 4:06 am

Re: Maya 2020

Post by mbonk » Fri Jan 08, 2021 3:09 am

ep19ma wrote:
Sat Dec 26, 2020 11:14 pm
https://www.youtube.com/watch?v=ETO4c9AcKpM maya2019 crash
Driver Version 10.7.1
Hi ep19ma,

I'm sorry, but I cannot follow what you are doing. Would it be possible to supply a description like a tutorial so that we can reproduce the steps that lead to the crash?

Markus

mbonk
Moderator
Moderator
Posts: 179
Joined: Mon Dec 04, 2006 4:06 am

Re: Maya 2020

Post by mbonk » Fri Jan 08, 2021 3:14 am

Janoshx wrote:
Wed Jan 06, 2021 3:17 am
The bug appears only if Rotation center has "Use selected item" selected.
Hi Janoshx,
We have verified the issue.
Thank you for your help.
Markus

mbonk
Moderator
Moderator
Posts: 179
Joined: Mon Dec 04, 2006 4:06 am

Re: Maya 2020

Post by mbonk » Fri Jan 08, 2021 3:17 am

Braldye wrote:
Thu Dec 31, 2020 9:41 am
Crashes when merging vertices and other various operations that perform a similar function in Maya 2020.
Hi Braldye,

Would it be possible for you to supply us a tutorial like description of the actions required to reproduce the issue(s)?

Markus

ep19ma
Posts: 5
Joined: Sat Dec 26, 2020 7:11 am

Re: Maya 2020

Post by ep19ma » Fri Jan 08, 2021 11:02 am


mbonk
Moderator
Moderator
Posts: 179
Joined: Mon Dec 04, 2006 4:06 am

Re: Maya 2020

Post by mbonk » Mon Jan 11, 2021 1:33 am

ep19ma wrote:
Fri Jan 08, 2021 11:02 am
https://www.youtube.com/watch?v=NKTbar0bnTc
Hi ep19ma,

Thanks, I can reproduce a crash following the actions in the video. For the crash to happen 'Use Selected Item' needs to be check in the 3Dconnexion properties -> Advanced Settings->Rotation Center for Maya. Can you confirm that this is also the case for you, please?

Markus

ep19ma
Posts: 5
Joined: Sat Dec 26, 2020 7:11 am

Re: Maya 2020

Post by ep19ma » Thu Jan 14, 2021 10:12 pm

The good news is that installing the 3dxware 10.7.0 driver can prevent the multi cut tool from crashing, but it will crash again in the rig skin weight。

Janoshx
Posts: 39
Joined: Wed Jul 13, 2016 4:16 am

Re: Maya 2020

Post by Janoshx » Fri Feb 26, 2021 1:02 am

Is this fixed?

Latest driver 10.7.1 update is from 2020.12.15 and last entry in this thread this is from 2021.1.15... and we are soon in March...

I would like to know status before trying?

mbonk
Moderator
Moderator
Posts: 179
Joined: Mon Dec 04, 2006 4:06 am

Re: Maya 2020

Post by mbonk » Fri Feb 26, 2021 4:13 am

Janoshx wrote:
Fri Feb 26, 2021 1:02 am
Is this fixed?
I'd wait for 10.7.2 should be fixed there.

ngomes
Moderator
Moderator
Posts: 2438
Joined: Mon Nov 27, 2006 7:22 am
Contact:

Re: Maya 2020

Post by ngomes » Fri Feb 26, 2021 5:06 am

mbonk wrote:
Fri Feb 26, 2021 4:13 am
Janoshx wrote:
Fri Feb 26, 2021 1:02 am
Is this fixed?
I'd wait for 10.7.2 should be fixed there.
Version 10.7.2 is expected to be released before end of March.

Post Reply