Heavy flickering of 3DxWare window under Linux

Questions and answers about 3Dconnexion devices on UNIX and Linux.

Moderator: Moderators

andpe
Posts: 5
Joined: Thu May 14, 2009 4:01 am
Location: Hamburg, Germany

Heavy flickering of 3DxWare window under Linux

Post by andpe » Thu May 14, 2009 4:11 am

I have installed the 3DxWare 1.4.1 under Linux.
xcube or xvalue are not working correctly. I cannot move the cube nor can I see any output with xvalue.
The only thing which happens is that all buttons in the 3DxWare window are changed frequently while touching my SpaceNavigator.

What is wrong?

Andreas

Bryan
Moderator
Moderator
Posts: 443
Joined: Thu Dec 07, 2006 1:37 pm
Location: Rochester NY

Heavy flickering of 3DxWare window under Linux

Post by Bryan » Thu May 14, 2009 9:00 am

Dear andpe,

Can you tell us a little more about your setup?

What hardware are you using?
What version of Linux?
Video Cards?

Do you have your device plugged directly into the computer?

What results have had previously or on another system?

Sincerely,
Bryan

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Fri May 15, 2009 5:24 am

Hello Andreas,

we recently found a problem with the SpaceNavigator on Linux :( . No motion data comes through. The internal bug number for this problem is #5067 (for your reference). We are working on a solution and I hope I can soon post here when we have a beta version ready for testing.

Uta Ludwig
3Dconnexion

andpe
Posts: 5
Joined: Thu May 14, 2009 4:01 am
Location: Hamburg, Germany

Re: Heavy flickering of 3DxWare window under Linux

Post by andpe » Fri May 15, 2009 5:42 am

Dear Bryan,

I just tested on another machine and had the same problem.
Machine 1:
****** XPC SD31P with PentiumD 3.4GHz, Nvidia Quadro FX 1400, 2GB RAM, OpenSuse 10.2
Machine 2:
****** XPC SN25P with Athlon X2 4200+, Nvidia Quadro FX 1500, 2GB RAM, OpenSuse 10.2

The SpaceNavigator is directly connected via USB to the computers.

Hope this helps,
Andreas

andpe
Posts: 5
Joined: Thu May 14, 2009 4:01 am
Location: Hamburg, Germany

Post by andpe » Fri May 15, 2009 5:50 am

uludwig wrote:Hello Andreas,

we recently found a problem with the SpaceNavigator on Linux :( . No motion data comes through. The internal bug number for this problem is #5067 (for your reference). We are working on a solution and I hope I can soon post here when we have a beta version ready for testing.

Uta Ludwig
3Dconnexion
Hallo Frau Ludwig,

ich hoffe, ich darf hier auf Deutsch schreiben.
Wollen Sie mir sagen, dass die SpaceNavigator zur Zeit gar nicht unter Linux funktioniert?
Bei mir werden immer dann, wenn ich die Maus berühre alle möglichen Sachen im "3DxWare 1.4.1"-Fenster verstellt. Besonders deutlich ist, dass sich der Text auf der ersten Seite bei "Tooltips" beim Berühren permanent verändert.
Haben Sie die gleichen Phänomene? Wann ist mit einem Fix zu Rechnen?

Schöne Grüße,
Andreas

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Heavy flickering of 3DxWare window under Linux

Post by UtaSH » Mon May 18, 2009 8:20 am

Hi Andreas,

we have a bug fix now for the problem with the SpaceNavigator on Linux. I'll send you a beta version of the driver. It will be version 1.4.3.

Uta Ludwig
3Dconnexion

muegyver
Posts: 2
Joined: Mon May 18, 2009 12:10 pm

Post by muegyver » Mon May 18, 2009 12:19 pm

I've just received my shiny new USB SpaceNavigator and am having exactly the same issue with 3DxWareUNIX V1.4.0 x86_64 :(

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Post by UtaSH » Tue May 19, 2009 6:28 am

Hi muegyver,

I'll send you a beta version of 3DxWareUnix that includes the fix for this phenomenon. Please post your findings here. Thanks!

Uta

muegyver
Posts: 2
Joined: Mon May 18, 2009 12:10 pm

Post by muegyver » Tue May 19, 2009 4:59 pm

Many thanks Uta, the beta version works beautifully!

aglef
Posts: 3
Joined: Thu May 21, 2009 2:36 pm
Location: Germany

Post by aglef » Thu May 21, 2009 2:43 pm

Hi Uta,
I've just got my USB SpaceNavigator as birthday present and I have the same issue with 3dxware-linux-v1-4-1.i386.tar.gz. May I have the new driver please?
Aglef
SuSE 11.0,Linux 2.6.25 32bit;Blender 2.49a,3DxWareUNIX=V1.4.3,Device=SpaceNavigator
Firmware=V4.04

andpe
Posts: 5
Joined: Thu May 14, 2009 4:01 am
Location: Hamburg, Germany

Post by andpe » Mon May 25, 2009 1:45 am

Hello Uta,

thank you for the help. The new driver is working.

Andreas

aglef
Posts: 3
Joined: Thu May 21, 2009 2:36 pm
Location: Germany

Post by aglef » Wed May 27, 2009 10:05 am

Hello Uta,

I got the driver. Thank's for your help. Now it works.

Aglef
SuSE 11.0,Linux 2.6.25 32bit;Blender 2.49a,3DxWareUNIX=V1.4.3,Device=SpaceNavigator
Firmware=V4.04

qxsxfx
Posts: 2
Joined: Wed May 27, 2009 5:48 pm

Post by qxsxfx » Wed May 27, 2009 5:50 pm

May I have the new driver?

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Beta driver: 3DxWareUnix 1.4.3

Post by UtaSH » Thu May 28, 2009 1:56 am

Hi all,

many thanks for all your feedback. I appreciate it.
qxsxfx wrote:May I have the new driver?
Yes, sure you can have it. I'll send it to you.

For those who want to have the beta version of the driver with the fix for the SpaceNavigator, please send me a PM and I will contact you. Please specify your Linux distribution and your platform (x86_64 or i386).

Uta Ludwig
3Dconnexion

UtaSH
Moderator
Moderator
Posts: 3643
Joined: Mon Nov 27, 2006 10:34 am
Location: Munich, Germany
Contact:

Re: Beta driver: 3DxWareUnix 1.4.3

Post by UtaSH » Mon Jun 08, 2009 1:53 am

Hi all,

I forgot to mention that I need as well your email address. Please add it to the other information (Linux distribution, architecture).

We still want to do a thorough testing. But as soon as this is done we will provide the driver on our download page.

Uta

Post Reply